[Bioperl-l] HELP: script cannot find primer3, which has been properly instal

zhihua li lzhtom at hotmail.com
Tue Sep 26 22:41:22 EDT 2006


Brian,

I upgraded to 1.5.1 and the script works.  It seems that for primer3 module 
the newest bioperl and bioperl-run are required. Thank you very much!


Zhihua Li


>From: Brian Osborne <osborne1 at optonline.net>
>To: zhihua li <lzhtom at hotmail.com>
>CC: bioperl-l at lists.open-bio.org
>Subject: Re: [Bioperl-l] HELP: script cannot find primer3, which has been 
properly installed
>Date: Tue, 26 Sep 2006 10:57:04 -0400
>
>Zhihua Li,
>
>Your code is correct and code just like it runs correctly on my machine. 
My
>only suggestion is to upgrade your Bioperl core and run packages to 
version
>1.5.1, 1.4 is quite old and 1.5.1 is a significant improvement.
>
>Brian O.
>
>
>On 9/25/06 9:08 PM, "zhihua li" <lzhtom at hotmail.com> wrote:
>
> > I'm using Suse 10.0
> >
> >
> >> From: Brian Osborne <osborne1 at optonline.net>
> >> To: zhihua li <lzhtom at hotmail.com>, bioperl-l at lists.open-bio.org
> >> Subject: Re: [Bioperl-l] HELP: script cannot find primer3, which has 
been
> > properly installed
> >> Date: Mon, 25 Sep 2006 14:13:19 -0400
> >>
> >> zhihua li,
> >>
> >> Are you on a Unix machine or Cygwin?
> >>
> >> Brian O.
> >>
> >>
> >> On 9/24/06 11:46 PM, "zhihua li" <lzhtom at hotmail.com> wrote:
> >>
> >>> hi, netters
> >>>
> >>> i installed primer3_1.0b and bioperl-run-1.4 following the
> > instructions.
> >>> the source of primer3 executables is in
> >>> /home/zz/setup/primer3_1.0b/src/primer3_core.
> >>>
> >>> then i tried the script in the documentation for
> > bio::tool::run::primer3
> >>>
> >>> use Bio::Tools::Run::Primer3;
> >>> use Bio::SeqIO;
> >>>
> >>>   my $seqio = Bio::SeqIO->new(-file=>'input.1');
> >>>   my $seq = $seqio->next_seq;
> >>>   my $primer3 = Bio::Tools::Run::Primer3->new(-seq => $seq,
> >>>                                               -outfile => "temp.out",
> >>>                                               -path =>
> >>> "/home/zz/setup/primer3_1.0b/src/primer3_core");
> >>> $primer3->add_targets('PRIMER_MIN_TM'=>56, 'PRIMER_MAX_TM'=>90);
> >>> my $results = $primer3->run;
> >>>
> >>> but when i ran it, there was an error message saying that primer3
> > couldn't
> >>> be found.
> >>>
> >>> i'm pretty sure primer3 has been properly installed. 'cause when i 
went
> > to
> >>> the source directory /home/zz/setup/primer3_1.0b/src/, i could run 
the
> >>> program there using:
> >>>
> >>> ./primer3_core<input.2
> >>>
> >>> why couldn't the perl script find primer3?
> >>>
> >>> thanks a lot!
> >>>
> >>>
> >>> _______________________________________________
> >>> Bioperl-l mailing list
> >>> Bioperl-l at lists.open-bio.org
> >>> http://lists.open-bio.org/mailman/listinfo/bioperl-l
> >>
> >>
> >> _______________________________________________
> >> Bioperl-l mailing list
> >> Bioperl-l at lists.open-bio.org
> >> http://lists.open-bio.org/mailman/listinfo/bioperl-l
> >
> >
> > _______________________________________________
> > Bioperl-l mailing list
> > Bioperl-l at lists.open-bio.org
> > http://lists.open-bio.org/mailman/listinfo/bioperl-l
>
>
>_______________________________________________
>Bioperl-l mailing list
>Bioperl-l at lists.open-bio.org
>http://lists.open-bio.org/mailman/listinfo/bioperl-l




More information about the Bioperl-l mailing list