[Bioperl-l] error while remote blast against swissprot db

DeeGee gdorjee at hotmail.com
Sat Apr 21 15:14:05 EDT 2007


hi
how do i check to see if i've installed the bioperl on my system properly. i
think i installed the bioperl-1.5.2_101 version, but i can't say for sure.
althought i can use some of the modules like Bio::SearchIO and
Bio::SearchIO, i can't seem to get the remote blast working for some reason.
is this something to do with the bioperl installation? i'm using perl v5.6.1
built for sun4-solaris-64int. 
i tried to install the same bioperl version on my Linux machine which has
perl v5.8.5 built for i386-linux-thread-multi, and it seem to give me the
same problem with the remote blast.
your help would be much appreciated.
thanks


Chris Fields wrote:
> 
> What version of bioperl are you using?  I get an error but it is b/c  
> the ID doesn't exist.
> 
> ------------- EXCEPTION: Bio::Root::Exception -------------
> MSG: acc KPYK_ECOLI does not exist
> STACK: Error::throw
> STACK: Bio::Root::Root::throw /Users/cjfields/src/bioperl-live/Bio/ 
> Root/Root.pm:359
> STACK: Bio::DB::WebDBSeqI::get_Seq_by_acc /Users/cjfields/src/bioperl- 
> live/Bio/DB/WebDBSeqI.pm:181
> STACK: genpept.pl:21
> -----------------------------------------------------------
> 
> The actual accession is 'KPYK1_ECOLI'.
> 
> chris
> 
> On Apr 16, 2007, at 3:42 PM, DeeGee wrote:
> 
>>
>> hi
>> i tried the following code just to check the network, and it worked  
>> fine
>> except for the SwissProt part, for which i got the error message  
>> instead of
>> the sequence:
>>
>> ------------- EXCEPTION  -------------
>> MSG: swissprot stream with no ID. Not swissprot in my book
>> STACK Bio::SeqIO::swiss::next_seq
>> /usr/perl5/5.6.1/lib/Bio/SeqIO/swiss.pm:179
>> STACK Bio::DB::WebDBSeqI::get_Seq_by_acc
>> /usr/perl5/5.6.1/lib/Bio/DB/WebDBSeqI.pm:187
>> STACK toplevel bbbbb.pl:21
>> --------------------------------------
>>
>> #### check #####
>> #!/usr/bin/perl -w
>> use strict;
>> use Bio::DB::GenBank;
>> use Bio::DB::SwissProt;
>> use Bio::DB::GenPept;
>> use Bio::SeqIO;
>>
>> my $genpeptdb = new Bio::DB::GenPept();
>> my $genbankdb = new Bio::DB::GenBank();
>> my $swissdb = new Bio::DB::SwissProt();
>>
>> my $seqio = new Bio::SeqIO(-format => 'fasta',
>>                            -fh     => \*STDOUT);
>>
>> my $protseq = $genpeptdb->get_Seq_by_acc('O26717');
>> $seqio->write_seq($protseq);
>>
>> my $seq = $genbankdb->get_Seq_by_acc('AF303112');
>> $seqio->write_seq($seq);
>>
>> $protseq = $swissdb->get_Seq_by_acc('KPY1_ECOLI');
>> $seqio->write_seq($protseq);
>>
>> thanks a lot.
>>
>>
>> Chris Fields wrote:
>>>
>>> The 'verbose' setting doesn't change the way the BLAST query is sent,
>>> it just sends the raw output from the repeated attempts to retrieve
>>> the report (using the RID) to STDERR.  The error you saw won't be
>>> fixed by doing so.
>>>
>>> What I was interested in was the raw HTML output dumped to the
>>> screen.  If it is querying the NCBI server it should dump stuff that
>>> includes something like this:
>>>
>>> ...
>>> <HTML>
>>> <p></p>
>>> <!--
>>> QBlastInfoBegin
>>>          Status=WAITING
>>> QBlastInfoEnd
>>> --><p></p>
>>> <SCRIPT LANGUAGE="JavaScript"><!--
>>> ...
>>>
>>> which indicates you have a request in the BLAST queue.  If you aren't
>>> seeing anything then the problem is likely network-related on your
>>> end, so getting the latest RemoteBlast won't help.  Do any other
>>> BioPerl modules requiring network access work (Bio::DB::GenBank, for
>>> instance)?  If not it could be a proxy issue...
>>>
>>> Just in case, here's the browsable CVS location for RemoteBlast:
>>>
>>> http://cvs.bioperl.org/cgi-bin/viewcvs/viewcvs.cgi/bioperl-live/Bio/
>>> Tools/Run/RemoteBlast.pm?cvsroot=bioperl
>>>
>>> Click on the download link and save over your local version.
>>>
>>> chris
>>>
>>> On Apr 16, 2007, at 2:10 PM, DeeGee wrote:
>>>
>>>>
>>>> hi Chris,
>>>> thanks for your reply. i set the RemoteBlast factory to a verbosity
>>>> of 1,
>>>> and i get the same error message. i'm new to all these. so, could
>>>> you plz
>>>> tell me how can i do the RemoteBlast in CVS that you've suggested.
>>>>
>>>> cheers!!!
>>>
>>>
>>> _______________________________________________
>>> Bioperl-l mailing list
>>> Bioperl-l at lists.open-bio.org
>>> http://lists.open-bio.org/mailman/listinfo/bioperl-l
>>>
>>>
>>
>> -- 
>> View this message in context: http://www.nabble.com/error-while- 
>> remote-blast-against-swissprot-db-tf3577674.html#a10024333
>> Sent from the Perl - Bioperl-L mailing list archive at Nabble.com.
>>
>> _______________________________________________
>> Bioperl-l mailing list
>> Bioperl-l at lists.open-bio.org
>> http://lists.open-bio.org/mailman/listinfo/bioperl-l
> 
> Christopher Fields
> Postdoctoral Researcher
> Lab of Dr. Robert Switzer
> Dept of Biochemistry
> University of Illinois Urbana-Champaign
> 
> 
> 
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l
> 
> 

-- 
View this message in context: http://www.nabble.com/error-while-remote-blast-against-swissprot-db-tf3577674.html#a10120148
Sent from the Perl - Bioperl-L mailing list archive at Nabble.com.



More information about the Bioperl-l mailing list