[Bioperl-l] Fwd: nonstop repeated output from Remote_blast with xml

Chris Fields cjfields at uiuc.edu
Thu Aug 2 13:05:55 EDT 2007


For archiving purposes; of course I forgot to cc the list!

-c

Begin forwarded message:

> From: Chris Fields <cjfields at uiuc.edu>
> Date: August 2, 2007 12:04:59 PM CDT
> To: gyang at plantbio.uga.edu
> Subject: Re: [Bioperl-l] nonstop repeated output from Remote_blast  
> with xml
>
> Guojun,
>
> Make sure to keep this on the mail list for archiving purposes.
>
> It could be that the RID is not being removed properly (if it isn't  
> removed then you will repeatedly retrieve your BLAST report).  The  
> new error you are seeing may be coming from whatever XML::SAX  
> backend parser is being used (XML::SAX::ExpatXS, XML::SAX::Expat,  
> etc); it doesn't look bioperl-related and there is an eval which  
> catches this stuff in SearchIO::blastxml.  Does text parsing work?
>
> Could you directly send me your script or add it to a new bug  
> report as an attachment?
>
> http://www.bioperl.org/wiki/Bugs
>
> chris
>
> On Aug 2, 2007, at 11:07 AM, Guojun Yang wrote:
>
>> Hi,Chris,
>> I installed the latest version of bioperl, in addition to the  
>> repeated output problem, there are new problems with parsing:
>>
>>
>> -------------------- WARNING ---------------------
>> MSG: error in parsing a report:
>>  No close tag marker [Ln: 4126, Col: 0]
>>
>> ---------------------------------------------------
>>
>> Would you please kindly give me a hint on this,
>> Thanks a lot,
>> Guojun
>>
>>
>> ----- Original Message -----
>> From: Chris Fields [mailto:cjfields at uiuc.edu]
>> To: gyang at plantbio.uga.edu
>> Cc: bioperl-l List [mailto:bioperl-l at lists.open-bio.org]
>> Subject: Re: [Bioperl-l] nonstop repeated output from Remote_blast  
>> with xml
>>
>>
>>> Make sure to keep responses on the ail list.
>>>> You might want to run a full install, just in case.  If I remember
>>> correctly Sendu made some changes a while back in the BLAST-related
>>> modules which may be related to this.  At the very least install/
>>> upgrade all modules in Bio::Tools::Run.
>>>> chris
>>>> On Jul 31, 2007, at 9:40 AM, Guojun Yang wrote:
>>>>> Thanks, Chris,
>>>> But when I replaced the old RemoteBlast.pm with the new one, I got
>>>> "can't locate the object method "retrieve_parameter"". Does this
>>>> mean I need to install something else?
>>>> Guojun
>>>>
>>>> ----- Original Message -----
>>>> From: Chris Fields [mailto:cjfields at uiuc.edu]
>>>> To: gyang at plantbio.uga.edu
>>>> Cc: bioperl-l at bioperl.org
>>>> Subject: Re: [Bioperl-l] nonstop repeated output from Remote_blast
>>>> with xml
>>>>
>>>>
>>>>>> On Jul 30, 2007, at 3:58 PM, Guojun Yang wrote:
>>>>>>> I am running remoteblast and using readmethod "xml", I  
>>>>>>> noticed that
>>>>>> it is printing the output repeatedly nonstop. It's like in a  
>>>>>> loop.
>>>>>> Did anybody notice this before? Can anybody help me getting  
>>>>>> out of
>>>>>> this?
>>>>>> Thanks a lot,
>>>>>>
>>>>>>
>>>>>> Guojun Yang
>>>>>> University of Georgia
>>>>>> Not seeing that using bioperl-live; you may need to update
>>>>> RemoteBlast.pm as this sounds similar to an issue that popped up
>>>>> earlier in the spring.
>>>>>> chris
>>>>>
>>>> Christopher Fields
>>> Postdoctoral Researcher
>>> Lab of Dr. Robert Switzer
>>> Dept of Biochemistry
>>> University of Illinois Urbana-Champaign
>>>>>>
>
> Christopher Fields
> Postdoctoral Researcher
> Lab of Dr. Robert Switzer
> Dept of Biochemistry
> University of Illinois Urbana-Champaign
>
>
>

Christopher Fields
Postdoctoral Researcher
Lab of Dr. Robert Switzer
Dept of Biochemistry
University of Illinois Urbana-Champaign





More information about the Bioperl-l mailing list