[Bioperl-l] Remote blast

Chris Fields cjfields at uiuc.edu
Mon Feb 26 09:59:21 EST 2007


I tested this out and got BLAST to work for my test case (single  
fasta seq, since you didn't send any seqs for testing).  It keeps  
querying for the RID in what appears to be an infinite loop (i.e. it  
doesn't get rid of the RID properly); you can see this if you add '- 
verbose => 1' to your parameters.  I don't have time to delve into it  
but from a quick glance it may be due to your looping structure and  
how you are saving your rids.

As for your particular error, could it be something as simple as the  
server was overloaded or down?  It does happen from time to time...

Beyond that I can't make heads or tails of your script.  Was it  
cobbled together from a bunch of others?  If you are doing that you  
can probably expect some bugs to occur.

chris

On Feb 25, 2007, at 11:23 PM, Sanjib Kumar Gupta wrote:

> Hi
> I have been running this script for some time and it was running  
> fine. I am
> using this linux machine with live IP(no proxy). But suudenly it  
> has stopped
> working with this errors
>
> waiting...waiting...
> -------------------- WARNING ---------------------
> MSG:  <HTML>
> <HEAD><TITLE>An Error Occurred</TITLE></HEAD>
> <BODY>
> <H1>An Error Occurred</H1>
> 500 Can't connect to www.ncbi.nlm.nih.gov:80 (Bad
> hostname 'www.ncbi.nlm.nih.gov')
> </BODY>
> </HTML>
>
> ---------------------------------------------------
> xx.pep
>
> -------------------- WARNING ---------------------
> MSG: req was POST http://www.ncbi.nlm.nih.gov/blast/Blast.cgi
> User-Agent: bioperl-Bio_Tools_Run_RemoteBlast/1.5
> Content-Length: 497
> Content-Type: application/x-www-form-urlencoded
>
> DATABASE=nr&QUERY=%3ENM_005277.3%3B_1414961_1+837%
> 0AMEENMEEGQTQKGCFECCIKCLGGIPYASLIATILLYAGVALFCGCGHEALSGTVNILQTYFEMARTA 
> GDTLDVF
> TMIDIFKYVIYGIAAAFFVYGILLMVEGFFTTGAIKDLYGDFKITTCGRCVSAWFIMLTYLFMLAWLGVT 
> AFTSLPV
> YMYFNLWTICRNTTLVEGANLCLDLRQFGIVTIGEEKKICTVSENFLRMCESTELNMTFHLFIVALAGAG 
> AAVIAMV
> HYLMVLSANWAYVKDACRMQKYEDIKSKEEQELHDIHSTRSKERLNAYT*&COMPOSITION_BASED_S 
> TATISTI
> CS=off&EXPECT=1e-
> 10&SERVICE=plain&FORMAT_OBJECT=Alignment&CMD=Put&MATRIX_NAME=BLOSUM62& 
> ENTREZ_
> QUERY=Xenopus+laevis[Organism]&PROGRAM=blastp
>
> <HTML>
> <HEAD><TITLE>An Error Occurred</TITLE></HEAD>
> <BODY>
> <H1>An Error Occurred</H1>
> 500 Can't connect to www.ncbi.nlm.nih.gov:80 (Bad
> hostname 'www.ncbi.nlm.nih.gov')
> </BODY>
> </HTML>
>
> ---------------------------------------------------
> waiting...waiting...
> -------------------- WARNING ---------------------
> MSG:  <HTML>
> <HEAD><TITLE>An Error Occurred</TITLE></HEAD>
> <BODY>
> <H1>An Error Occurred</H1>
> 500 Internal Server Error
> </BODY>
> </HTML>
>
> ---------------------------------------------------
>
> Though I am able to see the ncbi page from browser but am unable to  
> ping ot
> trace route to the server.
>
> Please help me.



More information about the Bioperl-l mailing list