[Bioperl-l] Question on Tree : Last common ancestor / Internal Nodes

Himanshu Ardawatia himanshu.ardawatia at bccs.uib.no
Wed Jan 10 17:46:41 EST 2007


Yes it works now. I realized I had not completely uninstalled the older
version.

Thanks.
Himanshu
\\

On 1/10/07, Chris Fields <cjfields at uiuc.edu> wrote:
>
>
> > Himanshu Ardawatia wrote:
> > > Hi,
> > >
> > > I am using version 1.4 . With this version, I run the
> > script (the one
> > > you sent) and get the following error:
> > > Use of uninitialized value in pattern match (m//) at tree.pl line 7.
> > >
> > > -------------------- WARNING ---------------------
> > > MSG: Must provide a valid array reference for -nodes
> > > ---------------------------------------------------
> > > Can't call method "id" on an undefined value at tree.pl line 9.
> > >
> > >
> > > I then installed version 1.5.2. With this vesion I get the
> > following error:
> >
> > What error?
>
> Maybe he meant the same error above, just forgot to delete the line.
>
> > > And I get the same error as above .
> >
> > You probably didn't install 1.5.2 properly. Either you're
> > actually still using 1.4, or when 1.5.2 was installed not all
> > of 1.4 was first removed.
> >   Check your version number (
> > http://www.bioperl.org/wiki/FAQ#How_can_I_tell_what_version_of
> > _BioPerl_is_installed.3F
> > ), locate and manually delete your 1.4 installation and try
> > the 1.5.2 installation again.
> ...
>
> Also, a quick way to locate the version of Bioperl used by default in a
> script (including directories defined in PERL5LIB):
>
> (BTW, this came from 'Perl Hacks'):
>
> perldoc -l Bio::Perl
>
> Or whatever Bioperl module you want.
>
> BTW, I get the script to work on Mac OS X and WinXP, so I agree with
> Sendu:
> you likely have problems with different versions of Bioperl installed on
> your system causing conflicts.
>
> chris
>
>
>


More information about the Bioperl-l mailing list