[Bioperl-l] Taxon id null with load_seqdatabase.pl

Hilmar Lapp hlapp at gmx.net
Sun Jan 14 12:17:21 EST 2007


George, I presume you are still loading fasta-formatted files? These  
do not have a syntax for parsing or figuring out the species, so  
bioperl won't have one. If you somehow know the species/taxon, you  
can use that same SeqProcessor module you created to also set the  
species:

	$seq->species(Bio::Species->new(-classification=>[qw(thaliana  
Arabidopsis)]));

Better yet, also add the NCBI taxon ID, which is the most effective  
lookup:

	$seq->species(Bio::Species->new(
		-classification=>[qw(thaliana Arabidopsis)],
		-ncbi_taxid=>3702));

Hth,

	-hilmar

On Jan 10, 2007, at 9:33 PM, George Heller wrote:

> Hi all.
>
>   I just loaded Arabidopsis data into the bioentry and biosequence  
> tables in my Postgres database using load_seqdatabase.pl. I had  
> loaded the taxon data prior to this, using the  
> load_ncbi_taxonomy.pl. Yet, I see the taxon_id field in the  
> bioentry field is blank, after the loading.
>
>   Can anyone tell me why this might be happening? And perhaps what  
> needs to be done to correct this?
>
>   Thanks.
>   George
>
>
> ---------------------------------
> Access over 1 million songs - Yahoo! Music Unlimited.
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l

-- 
===========================================================
: Hilmar Lapp  -:-  Durham, NC  -:-  hlapp at gmx dot net :
===========================================================







More information about the Bioperl-l mailing list