[Bioperl-l] [Bioperl]problem with E-value

Chris Fields cjfields at uiuc.edu
Wed Jan 17 11:22:36 EST 2007


Is this a supported BLAST report (i.e. listed in Bio::SearchIO::blast  
POD)?  If so, could someone please file this as a bug along with an  
example report?  Or has this been fixed already?

chris

On Jan 17, 2007, at 8:17 AM, Sendu Bala wrote:

> lidaof wrote:
>> Hi Sendu,
>>
>> Thanks for your reply!
>> the blast result and my .pl file were attached with this mail as a
>> single compressed file(the first attachment)
>> and on the machine installed bioperl 1.5.2_100
>> the exactly wrong message like"
>> Argument "1e" isn't numeric in numeric comparison (<=>) at
>> /usr/lib/perl5/site_perl
>> /5.8.5/Bio/SearchIO/blast.pm line 661, <GEN1> line 50.
>> Argument "1e" isn't numeric in numeric comparison (<=>) at
>> /usr/lib/perl5/site_perl
>> /5.8.5/Bio/SearchIO/blast.pm line 661, <GEN1> line 78.
>> "
>> and on the machine installed bioperl 1.5.1,no wrong message
>> but the output result is Different!!!
>> and the different result are attached as the second attachment
>
> Thanks for those. Can you describe in detail exactly how you generated
> the blast report?
>
> The problem is that Bioperl is completely mis-parsing the results. No
> version of Bioperl is able to handle your blast report, because the
> blast parser seems to expect there to be alignments for those  
> 'Sequences
> producing significant alignments'.
>
> Until the parser is fixed (assuming your blast report is valid),  
> let me
> make it clear: do NOT use Bioperl to parse your blast report - the
> results are TOTALLY WRONG.
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l

Christopher Fields
Postdoctoral Researcher
Lab of Dr. Robert Switzer
Dept of Biochemistry
University of Illinois Urbana-Champaign





More information about the Bioperl-l mailing list