[Bioperl-l] [Bioperl]problem with E-value

Chris Fields cjfields at uiuc.edu
Wed Jan 17 13:17:19 EST 2007


Li, Sendu,

Following up on this, I generated two new multiquery BLAST reports  
(BLASTP and BLASTX) from the NCBI BLAST server.  I can't reproduce  
output similar to Li's example (where the BLASTX header line appears  
over and over).  It is entirely possible that a local v. 2.2.15 BLAST  
installation would generate different output.

Li, was the example file you sent generated from single query BLAST  
runs where the output was appended to the same file, or were they  
generated from a single BLAST run where the queries were all in one  
file?  There is a significant difference between the two.

Regardless, I am able to reproduce a bug where hits aren't created  
properly from BLAST hit tables (which should be easy to fix).  I'll  
file a bug report and work on this.

As a general note, if you are only interested in hits and not  
alignments you probably shouldn't use the regular BLAST text output.   
Try using -m8 -r -m9 BLAST tabular output and 'blasttable' parsing  
instead of 'blast' and maybe switch event handlers (all in the  
SearchIO HOWTO).

chris

On Jan 17, 2007, at 11:03 AM, Chris Fields wrote
...
> ...
> I plan on generating a new BLAST report (from the web, since I don't
> have 2.2.15 installed) with multiple queries and no alignments to see
> what happens (i.e. see if the new multiquery report is similar to
> this one).  If so, there is a 'wrap-up' section of the parser, where
> hit data not in alignments (in the table only) is used to generate
> Hit objects; it's dropping this data likely b/c there is no regex
> signalling the next result event.
>
> chris





More information about the Bioperl-l mailing list