[Bioperl-l] ActivePerl 5.8.8.820 Release

Nathan Haigh N.Haigh at sheffield.ac.uk
Tue Jan 30 18:23:59 EST 2007


I have just recieved news that ActivePerl 5.8.8.820 has been released. It fixes a few major bugs that we experienced when releasing Bioperl 1.5.2.
Without going into it in much detail - I'm on holiday :o) here are a few of the pertinent fixes:

For users:
It should have fixed bugs releaing to updating to the latest version of a module (from any repo) rather than just installing the one from
ActiveState's repo. Therefore, you should be able to say something like "install bioperl" or "upgrade bioperl" and you get the latest version
available rather than having to specifically tell it which verson of a package to install.

For developers:
It should also have fixed a bug whereby we we forced to implemented a redirect in the httpd.conf file. The bug resulted in PPM4 clients requesting
modules from our repo rather than ActiveStates.

The PPM GUI should now also support install and uninstall of modules with post-install and uninstall scripts


For the full change log see:
http://aspn.activestate.com/ASPN/docs/ActivePerl/5.8/changes-58.html

I haven't been able to test these changes as I'm on holiday. But if these changes fix problems we were having we should think about bumping up the min
requirement to ActivePerl 5.8.8.820 so save a lot of headaches.

Cheers
Nath


More information about the Bioperl-l mailing list