[Bioperl-l] error using standaloneblast through webserver

Alicia Amadoz Alicia.Amadoz at uv.es
Mon Jul 30 11:46:57 EDT 2007


Hi, i'm trying to run a bioperl script in linux with standaloneblast
from a webserver but I have the following error:

-------------------- WARNING ---------------------
MSG: cannot find path to blastall
---------------------------------------------------

I have tried several things to fix it as setting some environment
variables both directly through the shell and adding some code in my
script with,

BEGIN {
$ENV{PATH} .= ':/usr/local/blast-2.2.16';
$ENV{BLASTDIR} = '/usr/local/blast-2.2.16/'; 
$ENV{BLASTDATADIR} = '/usr/local/data/';
}

and with,

$local->executable('/usr/local/bin');
my $blast_report = $local->blastall($inputfilename); 

I have also checked that the webserver has permission of read and
execute in all blast executables and directories. But trying all of
these things it keeps showing the same error above.

Any more idea to solve this problem? My script works well when I use it
as a simply script and I've reboot the system several times when changes
where performed. 

Thanks to anyone who will be able to help me!
Regards,
Alicia




More information about the Bioperl-l mailing list