[Bioperl-l] Bio::DB::Fasta

Staffa, Nick (NIH/NIEHS) staffa at niehs.nih.gov
Tue Jun 5 22:00:34 EDT 2007


I am wondering if I knew what this error message exactly meant, if I could
discern my error. 
I don't see much difference in this program and programs that worked.
Can I assume that the new worked because an index file exists?
I don't know how the filehandle UTR_TT_GENES gets involved.
Maybe I should use some other module, but I really would like to have
get_Seq_by_id functionality.

The error message:
Dpse ortholog = Dpse_GA17307
fetching GA17307
Can't call method "seq" on an undefined value at Match-emNEWTEST.pl line 84,
<UTR_TT_GENES> line 4.

Relevant code:
#!/usr/bin/perl
#
#
#
use strict;
use Bio::DB::Fasta;
use Bio::Tools::SeqWords;
use Bio::Seq;
use Bio::SeqIO;
#
my $db = 
Bio::DB::Fasta->new('/home/staffa/clients/Kari/D_pse_genome/testit/TT_orthol
ogs_Dpse_genes.fa',
                                -makeid => \&make_my_id);
...
...
...
my $pse_obj = $db->get_Seq_by_id('GA17307');
my $pse_sequence = $pse_obj->seq;




Nick Staffa 
Telephone: 919-316-4569  (NIEHS: 6-4569)
Scientific Computing Support Group
NIEHS Information Technology Support Services Contract
(Science Task Monitor: John D. Grovenstein (grovens1 at niehs.nih.gov)
National Institute of Environmental Health Sciences
National Institutes of Health
Research Triangle Park, North Carolina





More information about the Bioperl-l mailing list