[Bioperl-l] basic questions

L Xu ryanx07 at hotmail.com
Tue Jun 12 13:17:18 EDT 2007


I reinstalled activePerl and BioPerl, now the activePerl is 5.8.8 build 820.
However, both scripts generated the same error with my computer. I tested 
the code in another WinXP computer with the same versions of activePerl and 
BioPerl, the one for the swissprot did work but the restriction enzyme 
generated the same error.

= = = Original message = = =

Hmm, it almost looks like you're having an issue with line breaks.

The 'swissprot stream with no ID' error made me think that perhaps? Perl 
wasn't seeing the second argument to get_sequence. And then your? new 
program has the error 'Can't use string? 
("Bio::Restriction::EnzymeCollecti")' where the end of the word is? cut off.

I don't know how ActivePerl handles Windows vs UNIX line breaks.? Are? there 
any example scripts that come with ActivePerl? If there are,? and they run 
correctly, perhaps you could look to see how the line? breaks are done and 
make sure the your program does it the same way.

Other than that, I'm not seeing an obvious answer to your problem --? anyone 
else have a suggestion?

Perhaps the easiest thing for you to do would be to reinstall BioPerl? and 
make sure that you run the full test suite and that all of the? tests pass. 
My guess is that something in your current setup is not? quite right.

Dave

___________________________________________________________
Sent by ePrompter, the premier email notification software.
Free download at http://www.ePrompter.com.

_________________________________________________________________
Get a preview of Live Earth, the hottest event this summer - only on MSN 
http://liveearth.msn.com?source=msntaglineliveearthhm



More information about the Bioperl-l mailing list