[Bioperl-l] First cut svn repository

George Hartzell hartzell at alerce.com
Thu Jun 28 15:43:38 EDT 2007


Chris Fields writes:
 > 
 > On Jun 28, 2007, at 1:06 PM, George Hartzell wrote:
 > 
 > > ...
 > > I'm not 100% sure what's going on here, but I'm inclined to say "get a
 > > real computer" (and yes, I'm typing this on a mac...).  I have a mac
 > > pro that runs FreeBSD-STABLE part time and it's ggrrreeaatt (as tony
 > > the tiger used to say)....
 > 
 > Ouch!  Though it could be worse (**coughwindowscough**).
 > 
 > > I think that we're having trouble with case sensitivity.  My only
 > > evidence is that I can see where there have been both HUMBETGLOA.FASTA
 > > and HUMBETGLOA.fasta in the tree at various times.  I can't figure out
 > > anything else that's weird about that file.  On the other hand, I
 > > can't see how this would cause the error you're seeing though.
 > 
 > Odd that other branches (including the main trunk) work but that one  
 > doesn't.
 > 
 > > The experiment would be to grab a usb or firewire disk (or even a
 > > memory stick), partition/format it as case sensitive (or even *unix*)
 > > and try to do
 > >
 > >  svn co svn+ssh://dev.open-bio.org/home/hartzell/bioperl/bioperl- 
 > > live/tags/release-0-9-2/t/data
 > >
 > > into it.  If it works, voila.  If not, I'll keep making stuff up, err,
 > > thinking about it.
 > >
 > > g.
 > 
 > I'll have to figure out why I can't get ssh keys to work locally to  
 > test it out more (I have a usb drive to test with); just don't have  
 > time at the moment.

I just did the experiment, and filename-insensitivity seems to be
breaking something.

I'm using an svn I picked up from http://www.codingmonkeys.de/mbo/.

I reformatted a memory stick to be case sensitive and co of

  bioperl/bioperl-live/tags/release-0-9-2/t 

worked, then I made a directory in my home dir (normal mac thing) and
got the same error as above.

I can get a copy of the trunk, so I'm inclined to ask someone to
mention the problem on the wiki and then just ignore it.

g.


More information about the Bioperl-l mailing list