[Bioperl-l] Issues with new Bio::Tools::Run modules for Genemark and Glimmer

Chris Fields cjfields at uiuc.edu
Thu Mar 1 18:08:46 EST 2007


I have been working on an Infernal wrapper (not finished yet but  
getting there) which does this:

# when run() is called, cmsearch is the program run...
my $factory = Bio::Tools::Run::Infernal->new('-program' =>'cmsearch',
                                               @params);

in Infernal.pm:

# for each program...
my %INFERNAL_PROGRAM = (
     ...
     cmsearch => [qw(h W informat toponly local noalign dumptrees  
thresh X inside
                 null2 learninserts hmmfb hmmweinberg hmmpad hmmonly  
hthresh beta noqdb
                 qdbfile hbanded hbandp banddump sums scan2bands)],
     ...
     );

then set in new() based on only the parameters listed for the  
program; I'm still toying with whether the program needs to be  
specified in the constructor prior to a run.  There are prob. other  
variations on this using AUTOLOAD and _set_from_args() etc.

chris

On Mar 1, 2007, at 4:46 PM, Mark Johnson wrote:

> Now that I'm using _set_from_args() and trying to get all the  
> options and switches working that I never use, it occurs to me that  
> a 4-in-1 module for Glimmer2/Glimmer3/GlimmerM/GllimmerHMM is not  
> going to fly due to the options and switches being different.  At  
> this point, I think I'm going to end up with a Genemark module, a  
> Glimmer2 module, and a Glimmer3 module.  Feh.




More information about the Bioperl-l mailing list