[Bioperl-l] a problem with standalone blast

zhihua li lzhtom at hotmail.com
Sun Mar 11 22:33:44 EDT 2007


HI all,

I know this is probably not a right question to ask here, 'cause it's 
solely blast, although i did try using standalone blastall module.  But I 
couldn't find any other suitable mailing lists. So i hope guys here could 
help me out.

Recently I got a problem when I tried to blast a nucleotide sequence 
against a database. The problem occured when I was using blast module in 
perl, but then i realized it was caused by blast directly.

The database was generated with formatdb and is correct, 'cause all other 
queries went through quite well.

The problematic query sequence is: 
>ENSG00000162825.7
GGGGAAGAAGATCAAAGAAGAAAGAAGAAGGGGAAGAAAAGAAGGGGAAGAAG

The only difference it has compared with other successful queries is that 
it's shorter .

After running blastn I got the following message:
[blastall] WARNING: ENSG00000162825.7: Could not calculate ungapped 
Karlin-Altschul parameters due to an invalid query sequence or its 
translation. Please verify the query sequence(s) and/or filtering options.

At first I thought it might have been masked out too much during the 
filtering process. So I ran it again with the filtering switched off.  
After that I got following error:
[blastall] ERROR: Threshold for extending hits, default if zero
      blastp 11, blastn 0, blastx 12, tblastn 13
      tblastx 13, megablast 0 [F] is bad or out of range [? to ?]

Could you help me out with this?

Thanks a lot!


                         Zhihua Li

_________________________________________________________________
ÓëÁª»úµÄÅóÓѽøÐн»Á÷£¬ÇëʹÓà MSN Messenger:  http://messenger.msn.com/cn  



More information about the Bioperl-l mailing list