[Bioperl-l] NCBI Blast via HTTP

Chris Fields cjfields at uiuc.edu
Wed Mar 14 13:05:56 EDT 2007


David,

The problem I am seeing (using a verbose set to 1) is repeated  
queries to retrieve the report using an RID that isn't removed.  The  
report retrieval works for all formats (Text, Tabular, XML) but the  
RID isn't removed in the case of tabular or text output, thus gets  
stuck in an infinite loop.  XML for some reason works just fine, so I  
suggest anyone who uses RemoteBlast to switch to XML format parsing  
for the time being until this is fixed.

my $remote_blastxml = Bio::Tools::Run::RemoteBlast->new
	  ('-prog'       => $prog,
            '-data'       => $db,
            '-readmethod' => 'xml',
            '-expect'     => $e_val,
	  );
	
$remote_blastxml->retrieve_parameter('FORMAT_TYPE', 'XML');

then submit as normal.

chris

On Mar 14, 2007, at 11:10 AM, dwaner at scitegic.com wrote:

> We have seen this too, and I think I have tracked it down to recent
> changes in NCBI's results page format.  Specifically, there is no  
> longer
> the QBlastInfo block that BioPerl uses to detect that the results are
> ready. There is also no closing PRE tag that BioPerl uses to detect  
> the
> end of the blast results text.
>
> Also, in looking at the BioPerl code, I see that  it is assuming that
> "QBlastInfoBegin" and "Status=READY" are on separate lines. This is  
> not
> always the case, and has caused failures for us in the past.
>
> I am looking into this now, and communicating with NCBI about the  
> format
> changes.   I will keep the BioPerl list updated when I know more.
>
> David Waner
> Bioinformatics Software Engineer
> Accelrys/SciTegic
>
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l

Christopher Fields
Postdoctoral Researcher
Lab of Dr. Robert Switzer
Dept of Biochemistry
University of Illinois Urbana-Champaign





More information about the Bioperl-l mailing list