[Bioperl-l] bioperl installation problem

Sendu Bala bix at sendu.me.uk
Sat Apr 26 19:30:56 EDT 2008


Sebastian Bassi wrote:
> I tried to install bioperl because I need to install cviewer.
> Here (http://www.pastecode.com.ar/f37c1cd60) are both stdout and sdterr outputs.
> 
> Here is one of the errors I get:
> 
> set_attribute: not a compat02 graph at
> /usr/local/share/perl/5.8.7/Graph.pm line 2394, <GEN0> line 10.
> sleeping for 3 seconds
> set_attribute: not a compat02 graph at
> /usr/local/share/perl/5.8.7/Graph.pm line 2394, <GEN1> line 14.

You're trying to install a very old version of Bioperl which apparently 
uses behaviour of the Graph module no longer supported:
http://search.cpan.org/~jhi/Graph-0.84/lib/Graph.pod#Backward_compatibility_with_Graph_0.2

Your options are to force install your desired version of Bioperl (if 
you don't need to use the modules that are causing the errors you get), 
downgrade your version of Graph to pre-0.2, or install the latest 
version of Bioperl (1.5.2 or from svn).


More information about the Bioperl-l mailing list