[Bioperl-l] PullHSP bug

Chris Fields cjfields at illinois.edu
Tue Dec 2 18:03:21 EST 2008


I found a silent bug while fixing some issues with SimpleAlign which  
are causing blast_pull tests to fail (HSP-related).  It appears that  
the query sequence ID is not being caught, causing  
LocatableSeq::get_nse() to throw an exception within SimpleAlign when  
using PullHSPI::get_aln.  It appears that the hit seq ID is caught  
properly, though (hence the oddness).  All other SearchIO.t tests pass.

Could you look into this?

ok 165
ok 166
ok 167

------------- EXCEPTION: Bio::Root::Exception -------------
MSG: Attribute id not set
STACK: Error::throw
STACK: Bio::Root::Root::throw /Users/cjfields/bioperl/bioperl-live/ 
STACK: Bio::LocatableSeq::get_nse /Users/cjfields/bioperl/bioperl-live/ 
STACK: Bio::SimpleAlign::add_seq /Users/cjfields/bioperl/bioperl-live/ 
STACK: Bio::Search::HSP::PullHSPI::get_aln /Users/cjfields/bioperl/ 
STACK: t/SearchIO/blast_pull.t:237
# Looks like you planned 287 tests but only ran 167.
# Looks like your test died just after 167.
  Dubious, test returned 255 (wstat 65280, 0xff00)
  Failed 120/287 subtests

Test Summary Report
t/SearchIO/blast_pull.t (Wstat: 65280 Tests: 167 Failed: 0)
   Non-zero exit status: 255
   Parse errors: Bad plan.  You planned 287 tests but ran 167.
Files=1, Tests=167,  1 wallclock secs ( 0.04 usr  0.01 sys +  0.34  
cusr  0.04 csys =  0.43 CPU)
Result: FAIL
Failed 1/1 test programs. 0/167 subtests failed.

More information about the Bioperl-l mailing list