[Bioperl-l] bioperl-live install issue on unix

Sean O'Keeffe limericksean at gmail.com
Tue Dec 9 14:27:49 EST 2008

seems fine to me?

cpan[1]> o conf
$CPAN::Config options from '/home/okeeffe/.cpan/CPAN/MyConfig.pm':
    commit             [Commit changes to disk]
    defaults           [Reload defaults from disk]
    help               [Short help about 'o conf' usage]
    init               [Interactive setting of all options]

    applypatch         undef
    auto_commit        [0]
    build_cache        [10]
    build_dir          [/home/okeeffe/.cpan/build]
    build_dir_reuse    undef
    build_requires_install_policy undef
    bzip2              undef
    cache_metadata     [1]
    check_sigs         undef
    colorize_debug     undef
    colorize_output    undef
    colorize_print     undef
    colorize_warn      undef
    commandnumber_in_prompt [1]
    commands_quote     undef
    cpan_home          [/home/okeeffe/.cpan]
    curl               undef
    dontload_list      undef
    ftp                [/usr/bin/ftp]
    ftp_passive        [1]
    ftp_proxy          []
    getcwd             [cwd]
    gpg                []
    gzip               [/bin/gzip]
    histfile           [/home/okeeffe/.cpan/histfile]
    histsize           [100]
    http_proxy         []
    inactivity_timeout [0]
    index_expire       [1]
    inhibit_startup_message [0]
    keep_source_where  [/home/okeeffe/.cpan/sources]
    load_module_verbosity undef
    lynx               [/usr/bin/lynx]
    make               [/usr/bin/make]
    make_arg           []
    make_install_arg   []
    make_install_make_command [/usr/bin/make]
    makepl_arg         [LIB=/home/okeeffe/bioperl]
    mbuild_arg         []
    mbuild_install_arg []
    mbuild_install_build_command [./Build]
    mbuildpl_arg       []
    ncftp              []
    ncftpget           []
    no_proxy           []
    pager              [/bin/less -isRR]
    password           undef
    patch              undef
    prefer_installer   undef
    prefs_dir          undef
    prerequisites_policy [ask]
    proxy_pass         undef
    proxy_user         undef
    randomize_urllist  undef
    scan_cache         [atstart]
    shell              [/bin/bash]
    show_unparsable_versions undef
    show_upload_date   undef
    show_zero_versions undef
    tar                [/bin/tar]
    tar_verbosity      undef
    term_is_latin      [1]
    term_ornaments     [1]
    test_report        undef
    unzip              [/usr/bin/unzip]
        0 [ftp://ftp.cs.tu-berlin.de/pub/lang/perl/CPAN/]
        1 [ftp://ftp.fu-berlin.de/unix/languages/perl/]
        2 [ftp://ftp.gwdg.de/pub/languages/perl/CPAN/]
    use_sqlite         [0]
    username           undef
    wait_list          undef
    wget               [/usr/bin/wget]
    yaml_load_code     undef
    yaml_module        undef

2008/12/9 Sendu Bala <bix at sendu.me.uk>:
> Sean O'Keeffe wrote:
>> Hi Sendu,
>> Tried your suggestion to no avail. Same error.
> Check all your CPAN settings (o conf) and make sure you don't have any
> uninstall settings anywhere else. None of the mbuild* options should have
> 'uninst' in them for starters, and clean up the make* options as well just
> in case.
>> 2008/12/9 Sendu Bala <bix at sendu.me.uk>:
>>> You have your CPAN configured to uninstall old modules before installing
>>> new
>>> ones. Try:
>>>> cpan
>>> cpan> o conf mbuild_install_arg ""
>>> cpan> o conf commit

More information about the Bioperl-l mailing list