[Bioperl-l] blast module errors with web app

Samantha Thompson Samantha.Thompson at greenbiologics.com
Tue Dec 9 15:24:31 EST 2008

I tried this env grep, theres nothing in my env variables with regards
to blast...

With the blast executables I gunzip'd them from ncbi and cp'd the
executables from the blast/bin directory of the distribution to my own
/usr/bin ...
When I run blastall from the command line anywhere it works fine... when
I run it in a normal perl script it works (in that the test script tells
me the number of hits on the command line) .... but when I run it from
within the Catalyst app it throws those exceptions... it may be because
it's trying to create that tmp directory when it runs and isn't able
to... I'm not sure how I would set those in Catalyst, but thats kind of
veering away from BioPerl into Catalyst.. I will try a few more


-----Original Message-----
From: Cook, Malcolm [mailto:MEC at stowers-institute.org] 
Sent: 09 December 2008 20:07
To: Samantha Thompson; 'bioperl-l List'
Subject: RE: blast module errors with web app

perhaps your environment underl Catalyst server is incomplete....

do this interactively:

> env | grep -i blast

do you see any blast related environment variables?

are they set in the Catalyst server process?

Just thinkin...

Malcolm Cook

> -----Original Message-----
> From: bioperl-l-bounces at lists.open-bio.org
> [mailto:bioperl-l-bounces at lists.open-bio.org] On Behalf Of
> Samantha Thompson
> Sent: Tuesday, December 09, 2008 1:35 PM
> To: bioperl-l List
> Subject: [Bioperl-l] blast module errors with web app
> Hi,
> I seem to be able to get stand alone blast to run ok, using a
> script like the one in the Beginner's HowTo ...
> But when running it embedded in my web app I get the following
> errors/exceptions:
> ------------- EXCEPTION: Bio::Root::Exception -------------
> MSG: blastall call crashed: -1 /usr/bin/blastall -d  "/src/GBLCCDB16s"
> -i  /tmp/FxXS98W1H0  -o  /tmp/6gp_EnCnsu  -p  blastn
> STACK: Error::throw
> STACK: Bio::Root::Root::throw
> /usr/lib/perl5/vendor_perl/5.10.0/Bio/Root/Root.pm:359
> STACK: Bio::Tools::Run::StandAloneBlast::_runblast
> /usr/lib/perl5/vendor_perl/5.10.0/Bio/Tools/Run/StandAloneBlast.pm:813
> STACK: Bio::Tools::Run::StandAloneBlast::_generic_local_blast
> /usr/lib/perl5/vendor_perl/5.10.0/Bio/Tools/Run/StandAloneBlast.pm:760
> STACK: Bio::Tools::Run::StandAloneBlast::blastall
> /usr/lib/perl5/vendor_perl/5.10.0/Bio/Tools/Run/StandAloneBlast.pm:570
> This comes from the stack trace of my Catalyst web app....
> I wonder if these particular exceptions mean anything to
> anyone. Does BLAST not like the database have folder names in
> it? Maybe theres a problem with the tmp folder not existing
> as part of my web app. Maybe I need to explicitly define the
> -i and -o parameters...
> Thanks,
> Sam
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l

More information about the Bioperl-l mailing list