[Bioperl-l] Using BLAT in BioPerl

Dave Messina David.Messina at sbc.su.se
Tue Dec 16 13:20:59 EST 2008

Hmm, tough to say what the problem is.
One thing I noticed that seems a little odd is your blatSearch.pl script
appears to be running in your /Users/ directory, which is normally owned by
root and not writable by regular users.

Also, it looks like it's attempting to create the temporary files in
/var/folders, which as far as I remember is also owned by root.

Not sure why running as root would necessarily cause a problem, but it's an
unusual scenario, so you might try running as a regular user in a directory
where you know you have write permissions.

Otherwise, you could create a minimal example of your problem, such as a
single small query sequence, a single small database, and a test script. You
could post these in a bug report to Bugzilla so that someone can try to
reproduce your problem.


On Mon, Dec 15, 2008 at 17:56, oso <oso.oro at gmail.com> wrote:

> Error Message:
> MSG: Blat call (blat
> /var/folders/zK/zKXnWXt8G8epLqENEIdNkE+++TI/-Tmp-/wcjQruYe8A
> /var/folders/zK/zKXnWXt8G8epLqENEIdNkE+++TI/-Tmp-/nePTpfPSKu -out=psl )
> crashed: 65280
> STACK Bio::Tools::Run::Alignment::Blat::_run
> /Library/Perl/5.8.8/Bio/Tools/Run/Alignment/Blat.pm:250
> STACK Bio::Tools::Run::Alignment::Blat::run
> /Library/Perl/5.8.8/Bio/Tools/Run/Alignment/Blat.pm:167
> STACK main::get_orfs /Users/blatSearch.pl:50
> STACK toplevel /Users/blatSearch.pl:29
> *******
> I am running BioPerl version 1.5.2.
> Thanks for our help!

More information about the Bioperl-l mailing list