[Bioperl-l] Bio::Graphics and perl 5.10

Chris Fields cjfields at uiuc.edu
Fri Feb 22 11:28:01 EST 2008


(cc'ing to gbrowse list as this pertains somewhat...)

Just added a bioperl bug report for this along with the png file  
output from perl 5.8 and perl 5.10:

http://bugzilla.open-bio.org/show_bug.cgi?id=2457

Lincoln's recent commits to Bio::Graphics::FeatureFile didn't fix the  
issue.  However, it is now pinpointing the problem for both perl 5.8  
and perl 5.10 (same warning for both, with only perl 5.10 failing):

1..35
ok 1 - use Bio::Graphics::FeatureFile;
ok 2 - use Bio::Graphics::Panel;
ok 3
Cosmid EST FGENESH SwissProt P-element / yk53c10.3 yk53c10.5 at Bio/ 
Graphics/FeatureFile.pm line 285.
not ok 4
#   Failed test at t/BioGraphics.t line 49.
#          got: '7'
#     expected: '5'
ok 5
ok 6
ok 7
ok 8
...

chris

On Feb 21, 2008, at 10:37 PM, Chris Fields wrote:

> I'm getting a single failed test for Bio::Graphics in bioperl-live  
> which appears to be perl 5.10-specific and is related to  
> Bio::Graphics::FeatureFile:
>
> t/BioGraphics......
> 1..35
> ok 1 - use Bio::Graphics::FeatureFile;
> ok 2 - use Bio::Graphics::Panel;
> ok 3
> not ok 4
>
> #   Failed test at t/BioGraphics.t line 49.
> #          got: '7'
> #     expected: '5'
> ok 5
> ok 6
> ok 7
> ok 8
> ...
>
> It appears to be coming from render() passing two extra tracks under  
> perl 5.10 over what is passed in perl 5.8.  If anyone is running  
> perl 5.10, can they test this out?
>
> chris
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l

Christopher Fields
Postdoctoral Researcher
Lab of Dr. Robert Switzer
Dept of Biochemistry
University of Illinois Urbana-Champaign





More information about the Bioperl-l mailing list