[Bioperl-l] bioperl on mac

Katherine Wendelsdorf wkath83 at vbi.vt.edu
Thu Jan 24 13:19:06 EST 2008


Dear one who knows,

I have a macbook with Leopard OSX and I am having trouble running scripts
that call for bioperl modules.

Here is my history: Using Fink I installed bioperl-pm586 version 1.5.2-4
and bioperl-run-pm586 version 1.5.2-1. when I type >which bioperl-pm586 in
to the command line I get nothing. Spotlight says that the path is
/sw/share/bioperl-pm586. The same goes for bioperl-run-pm586.

1. I tried to run test2.pl script that was literally copied and pasted
from the HOWTO manual, but it wouldnt run. The two attached docs are the
script I tried to run and the output (which is nonexistant). I read
something that said to "go in to" Bioperl to execute a command. I could
not enter the bioperl directory when it was in the sw/shared directory so
I copied the bioperl folder to the Desktop just so I could try executing
the script inside bioperl. Where am I going wrong here?

Should I place these folders (bioperl-pm586 and bioperl-run-pm586)
somewhere else on my computer? Shoudl they be in the same directory as
perl (usr/bin/perl)?

2. How do I know what modules are included in the bioperl-pm586 I
downloaded? Specifically I want to use Bio::SeqIO.

3. What is the best way to download/install new modules as I need them?


Any answers you coudl give me for any of these questions would be greatly
appreciated!

Thank you so much, kind volunteer!
-Kate
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: test.txt
URL: <http://lists.open-bio.org/pipermail/bioperl-l/attachments/20080124/d4d30eb5/attachment.txt>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: test2.pl
URL: <http://lists.open-bio.org/pipermail/bioperl-l/attachments/20080124/d4d30eb5/attachment.pl>


More information about the Bioperl-l mailing list