[Bioperl-l] Install help errors

Alex Lancaster alexl at users.sourceforge.net
Thu Jul 3 21:27:31 EDT 2008

>>>>> "DM" == Dave Messina  writes:

DM> Here's your problem -- bioperl 1.4 is waaaay out of date. Don't
DM> use that.

>> BIRNEY/bioperl-1.4.tar.gz : make_test NO

Instead, use the 1.5.2_100 version of bioperl-core that matches this:

>> SENDU/bioperl-db-1.5.2_100.tar.gz : make_test NO

DM> Or even better, you might want to get the latest versions of each from the
DM> bioperl website.
DM> Look here: http://www.bioperl.org/wiki/Getting_BioPerl
DM> and here: http://www.bioperl.org/wiki/Installing_BioPerl

Fedora does ship the latest bioperl (1.5.2) and bioperl-run, as
perl-bioperl and perl-bioperl-run, respectively see:


but we haven't yet packaged the bioperl-db module, but I could
certainly look into doing that.  

Is http://www.bioperl.org/wiki/Getting_BioPerl the best place to add
section a section on the Fedora packages for bioperl?  It would just
need to say something like: 

 To install bioperl (core) simply run (as root):

 yum install perl-bioperl

I do keep the Fedora packages up to date, so when the next bioperl is
released (any timeline for that?), it will be updated.

Incidentally why is 1.5.2 still called a "developer" release and 1.4
"stable", it just confuses users who tend to assume that the "stable"
release is the one they should install (and Linux distributions for
that matter).  1.5.2 is now already 3 or so years old, so it should be
considered the default release by now.


More information about the Bioperl-l mailing list