[Bioperl-l] Install help errors

Alex Lancaster alexl at users.sourceforge.net
Sat Jul 5 06:13:43 EDT 2008

>>>>> "SB" == Sendu Bala  writes:

SB> Alex Lancaster wrote:
>> should probably be re-opened, but at least looking at that bug it
>> seems the issue *was* fixed in that version, so hopefully Fedora
>> hasn't "consistently" been shipping a broken version of Perl since
>> then.

SB> So, advice to people with the problem should be?

Without knowing what version of Perl and Fedora they are using it's
hard to say (see below).

SB> yum update perl ?? 

Just: "yum update".

In general, people should be continually updating their system, so if
they are up-to-date they should be fine.

F-7: the last update of Perl appears to be perl-5.8.8-30.fc7, which
doesn't appear to have the fix.  F-7 is now end-of-lifed, so no new
updates to fix this are possible, all users are advised to upgrade to
at least F-8, but preferrably F-9.

F-8: current update is perl-5.8.8-40 and the fix was introduced into
perl-5.8.8-35, so if the F-8 is system is up to date you should be
good to go, I ran the test suggested in one this bug report:


on my F-8 box:

$ perl -MCompress::Zlib -e 0

and it runs without error.

F-9: ships with perl-5.10, not sure if this problem affects perl 5.10,
but "perl -MCompress::Zlib -e 0" also runs without error on my F-9 box.

SB> is this likely to solve the issue regardless of what version of
SB> fedora they're using?

Bottom line: assuming the fix in perl-5.8.8-35 (and later) did the
trick, then just make sure your are running on F-8 or later and be
fully up to date (using "yum update" or pup/packagekit, which should
be standard practice for all Fedora users anyway).

SB> If that doesn't work:

SB> cpan force install Scalar::Util

Please don't recommend that they do that because it will mess up the
installed Perl.  If they are on F-7, upgrade to F-8 or later.  If
there is still an error, ask them to re-open this bug:



More information about the Bioperl-l mailing list