[Bioperl-l] Bio_Tools_Run_RemoteBlast error: 500 Can't connect to www.ncbi.nlm.nih.gov:80

Alicia Amadoz Alicia.Amadoz at uv.es
Mon Jul 21 11:24:24 EDT 2008


Hi,

I have tried what you suggested and what I get is another error:

------------- EXCEPTION: Bio::Root::Exception -------------
MSG: WebDBSeqI Request Error:
500 Can't connect to eutils.ncbi.nlm.nih.gov:80 (Bad hostname 'eutils.ncbi.nlm.nih.gov')
Content-Type: text/plain
Client-Date: Mon, 21 Jul 2008 15:07:39 GMT
Client-Warning: Internal response

500 Can't connect to eutils.ncbi.nlm.nih.gov:80 (Bad hostname 'eutils.ncbi.nlm.nih.gov')

STACK: Error::throw
STACK: Bio::Root::Root::throw /usr/lib/perl5/vendor_perl/5.8.8/Bio/Root/Root.pm:359
STACK: Bio::DB::WebDBSeqI::_stream_request 
/usr/lib/perl5/vendor_perl/5.8.8/Bio/DB/WebDBSeqI.pm:758
STACK: Bio::DB::WebDBSeqI::get_seq_stream 
/usr/lib/perl5/vendor_perl/5.8.8/Bio/DB/WebDBSeqI.pm:454
STACK: Bio::DB::WebDBSeqI::get_Stream_by_id 
/usr/lib/perl5/vendor_perl/5.8.8/Bio/DB/WebDBSeqI.pm:275
STACK: /var/www/html/perl-cgi//remote_blast_ncbi.pl:48
-----------------------------------------------------------

in line 48 of my script is,

my $seqio = $gb->get_Stream_by_id([qw(J00522 AF303112 2981014)]);

>  From the original script you appear to be running things from a PHP  
> environment, so maybe it has something to do with that, e.g. maybe you  
> need to set other env. settings (like a proxy) in order to connect.

I am going to check again php.info but I have no idea what can it be. 

Thanks again for your help.
Alicia





More information about the Bioperl-l mailing list