[Bioperl-l] Enquery about the Bio::Tools::Run::Alignment::Blat module

George Hartzell hartzell at alerce.com
Thu Oct 16 22:29:32 EDT 2008


On Thu, 2008-10-16 at 16:28 -0500, pan tong wrote:
> Dear bioperl team,
> 
> I'm a graduate student. I've just begun using bioperl to conduct my
> research. I found the modules provided by bioperl very useful. Besides,
> there are many documents describing each module which is very helpful.
> 
> However, when I search the Blat module, there seems to be little example or
> document about it. I have problems while using the blat module.
> 
> Here is my code:
> ----------------------------------------------------------------------------------------------------------------
> #!/usr/bin/perl
> use strict;
> use warnings;
> use Bio::SeqIO;
> use Bio::Tools::Alignment::Blat;
> 
> my $in= Bio::SeqIO->new(-file=>'124_Dmel_Enc[1][1].fa.txt' , '-format' =>
> 'Fasta' );
> while ( my $seq_object = $in->next_seq() )
> {
>     my $seq=$seq_object->seq();
>     #print "$seq\n";
>     my $factory = Bio::Tools::Alignment::Blat->new();
>     my $DB='D.melanogaster';
>     my @feats = $factory->run($seq_object,$DB);
> }
> ---------------------------------------------------------------------------------------------------------------
> When I excute it, the program exit with "Can't locate object method "new"
> via package "Bio::Tools::Alignment::Blat"..."
> Can you help modify my code? Or can you give me a detailed sample code of
> Blat so that I can refer?
> By the way, I need to specify Genome with D.melanogaster when I call the
> blat module.
> 

I think that you should be using

Bio::Tools::Run::Alignment::Blat

You'll need to change the use statement at line 5 and the package that
you specify in the call to ->new().

I'm kind of surprised that your 'use' statement at line 5 actually works
as is.

g.





More information about the Bioperl-l mailing list