[Bioperl-l] Plse help! Probs with SeqIO in web service (web form)!!!

Mark A. Jensen maj at fortinbras.us
Wed Feb 11 21:37:04 EST 2009

The 'Invalid argument' appears to be thrown in DOS when there is not enuf space
in the partition. In any case, this is pretty clearly an OS issue- Don't forget 
too that
the web server prob doesn't have the same permissions when running the script
as the user, even when running it in the same place. MAJ
----- Original Message ----- 
From: "Julio514" <suedejohnny at hotmail.com>
To: <Bioperl-l at lists.open-bio.org>
Sent: Sunday, February 08, 2009 2:26 PM
Subject: [Bioperl-l] Plse help! Probs with SeqIO in web service (web form)!!!

> Hello everyone,
> I've been using bioperl for more than one year now. Recently, I started a
> project of establishing a web service that accept for input one or many
> fasta sequences. I tested my script offline with .fa files directly on my HD
> to make sure everything was fine. And it was... After that, I modified the
> script with some CGI lines to make it compatible with web forms. (btw I
> still am a noob in web services:)). Anyway, the fasta input sequences seems
> to cause a prob I never encountered before and I am clueless... Here it is:
> Error in tempdir() using \\\\XXXXXXXXXX: Could not create directory
> \\\\6RzqdL7zU9: Invalid argument at C:/perl/site/lib/Bio/Root/IO.pm line
> 744,
> Anyone ever saw that ?
> I made sure that my $ENV{TMPDIR} was NOT read-only...
> Cheers,
> -- 
> View this message in context: 
> http://www.nabble.com/Plse-help%21-Probs-with-SeqIO-in-web-service-%28web-form%29%21%21%21-tp21902369p21902369.html
> Sent from the Perl - Bioperl-L mailing list archive at Nabble.com.
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l

More information about the Bioperl-l mailing list