[Bioperl-l] Fw: broken Bio::SeqIO in bioperl on OS X (fink)

Koen van der Drift kvddrift at earthlink.net
Thu Feb 26 15:12:29 EST 2009


Hi,

I am forwarding this message from a user of the bioperl package installed through fink on Mac OS X. I don't know what it means, so I told him I would ask here. If it's not a bioperl issue, I will check with the fink folks.

thanks in advance,

- Koen.




-----Forwarded Message-----
>
>
>Hi Koen,
>
>Hope this finds you well.  I wanted to let you know about a bug in  
>bioperl-pm588.
>
>Tried a script (i.e., mitobank.pl from David Posada's lab) on Ubuntu  
>8.04/8.10 with bioperl (1.5.2.102-1ubuntu1/1.5.2.102-3) and works fine.
>
>Tried same script in Leopard 10.5.6 with completely updated fink and  
>bioperl-pm588 (1.6.0-1) produces the following error:
>
>srsantos at santos-mac-pro:~/Desktop$ mitobank.pl 6681 > log.txt
>Use of uninitialized value in concatenation (.) or string at /System/ 
>Library/Perl/5.8.8/darwin-thread-multi-2level/Scalar/Util.pm line 30.
>Bio::SeqIO: genbank cannot be found
>Exception
>------------- EXCEPTION -------------
>MSG: Failed to load module Bio::SeqIO::genbank. Weak references are  
>not implemented in the version of perl at /sw/lib/perl5/5.8.8/Bio/ 
>Species.pm line 91
>BEGIN failed--compilation aborted at /sw/lib/perl5/5.8.8/Bio/ 
>Species.pm line 91.
>Compilation failed in require at /sw/lib/perl5/5.8.8/Bio/SeqIO/ 
>genbank.pm line 172.
>BEGIN failed--compilation aborted at /sw/lib/perl5/5.8.8/Bio/SeqIO/ 
>genbank.pm line 172.
>Compilation failed in require at /sw/lib/perl5/5.8.8/Bio/Root/Root.pm  
>line 420.
>
>STACK Bio::Root::Root::_load_module /sw/lib/perl5/5.8.8/Bio/Root/ 
>Root.pm:422
>STACK (eval) /sw/lib/perl5/5.8.8/Bio/SeqIO.pm:551
>STACK Bio::SeqIO::_load_format_module /sw/lib/perl5/5.8.8/Bio/SeqIO.pm: 
>550
>STACK Bio::SeqIO::new /sw/lib/perl5/5.8.8/Bio/SeqIO.pm:372
>STACK Bio::DB::WebDBSeqI::get_seq_stream /sw/lib/perl5/5.8.8/Bio/DB/ 
>WebDBSeqI.pm:459
>STACK Bio::DB::NCBIHelper::get_Stream_by_query /sw/lib/perl5/5.8.8/Bio/ 
>DB/NCBIHelper.pm:276
>STACK toplevel /Users/srsantos/UNIXBioInfo/perl/mitobank.pl:79
>-------------------------------------
>
>
>For more information about the SeqIO system please see the SeqIO docs.
>This includes ways of checking for formats at compile time, not run time
>Can't locate object method "new" via package "Bio::SeqIO::genbank" at / 
>sw/lib/perl5/5.8.8/Bio/SeqIO.pm line 373.
>srsantos at santos-mac-pro:~/Desktop$
>
>Message "Bio::SeqIO: genbank cannot be found" suggests Bio::SeqIO is  
>broken in the fink package.
>
>Please let me know if you need additional information.
>
>Cheers,
>
>Scott




More information about the Bioperl-l mailing list