[Bioperl-l] parsing a phyloxml file

Chris Fields cjfields at illinois.edu
Thu Jan 29 20:09:14 EST 2009


Also, the phyloxml regression tests should at least indicate a problem  
with the module.  If they are passing then there is another problem at  
hand, either with the tests skipping based on a bad module (should  
fail) or .

 From the base directory of a BioPerl core (either main trunk or 1.6):

./Build test --test-files t/Tree/TreeIO/phyloxml.t --verbose

chris

On Jan 29, 2009, at 4:31 PM, Hilmar Lapp wrote:

> Chrysanthi,
>
> if your error message still says
>
> 'XML::LibXML::Reader module - your libxml2 is compiled without  
> reader support!'
>
> then in all likelihood that is precisely your problem. NEXUS or  
> newick are not XML formats and hence whether they work or not says  
> nothing as to why you are getting this error.
>
> Chris also indicates that after updating your libxml2 you will have  
> to recompile and reinstall XML::LibXML so that it recognized and  
> compiles with the newer libxml2 capabilities. Have you done that?
>
> 	-hilmar
>
> On Jan 29, 2009, at 4:24 PM, Chrysanthi A. wrote:
>
>> Hi,
>>
>> Yes, I updated library with the last version of libxml2 (2.6.27),  
>> but I get
>> again the same problem? Trying to parse files of nexus or newick  
>> format, I
>> do not have any problem.. I read in the bioperl wiki that "the  
>> phyloxml tree
>> format will be supported in the next release".. So, I am supposing  
>> that
>> maybe the problem is with the format tha I am using. Am I right?  
>> Which is
>> the newest version? Is there another way to parse the file?
>>
>> Thanks a lot for your help,
>>
>> Chrysanthi
>>
>>
>> 2009/1/28 Chris Fields <cjfields at illinois.edu>
>>
>>> Chrysanthi,
>>>
>>> Make sure to keep the mail list in your replies.
>>>
>>> Did you update the libxml2 library (http://xmlsoft.org/) to at least
>>> libxml2-2.6.21?  Make sure you don't have libxml instead (aka  
>>> libxml v1).
>>> Most repos (apt, yum, fink, macports) have the updated version.
>>>
>>> I believe XML::LibXML will compile if you have an older libxml  
>>> version, but
>>> it will skip Reader and other modules that don't have a minimum  
>>> libxml
>>> library present (and older versions of Reader are not API- 
>>> compliant if I
>>> recall correctly).
>>>
>>> chris
>>>
>>>
>>> On Jan 28, 2009, at 10:59 AM, Chrysanthi A. wrote:
>>>
>>> I updated the version but I am getting again the same error. Why?  
>>> Is there
>>>> another way in order to parse a phyloxml file?
>>>>
>>>> Thanks a lot,
>>>>
>>>> Chrysanthi.
>>>>
>>>>
>>>> 2009/1/28 Chris Fields <cjfields at illinois.edu>
>>>>
>>>> On Jan 28, 2009, at 9:40 AM, Chrysanthi A. wrote:
>>>>
>>>> Hi,
>>>>
>>>> I am trying to parse a phyloxml file but I get the message error  
>>>> below:
>>>>
>>>> Bio::TreeIO: phyloxml cannot be found
>>>> Exception
>>>> ------------- EXCEPTION -------------
>>>> MSG: Failed to load module Bio::TreeIO::phyloxml. Cannot use
>>>> XML::LibXML::Reader module - your libxml2 is compiled without  
>>>> reader
>>>> support! at
>>>> /System/Library/Perl/5.8.8/darwin-thread-multi-2level/XML/LibXML/ 
>>>> Reader.pm
>>>> line 17
>>>>
>>>> Helps to read the error message.  You need an updated  
>>>> XML::LibXML, a
>>>> version that has XML::LibXML::Reader support.  It requires an up- 
>>>> to-date
>>>> libxml.  See:
>>>>
>>>>
>>>> http://search.cpan.org/~pajas/XML-LibXML-1.69/lib/XML/LibXML/Reader.pod#DESCRIPTION 
>>>> <http://search.cpan.org/%7Epajas/XML-LibXML-1.69/lib/XML/LibXML/Reader.pod#DESCRIPTION 
>>>> >
>>>>
>>>> chris
>>>>
>>>>
>>>>
>>>>
>>>
>> _______________________________________________
>> Bioperl-l mailing list
>> Bioperl-l at lists.open-bio.org
>> http://lists.open-bio.org/mailman/listinfo/bioperl-l
>
> -- 
> ===========================================================
> : Hilmar Lapp  -:-  Durham, NC  -:-  hlapp at gmx dot net :
> ===========================================================
>
>
>



More information about the Bioperl-l mailing list