[Bioperl-l] Fwd: Bioperl Installation

Scott Cain scott at scottcain.net
Mon Jul 6 16:50:41 EDT 2009


Hi Dave,

I think you are confused about the prereqs for Data::Stag: I have it
installed and working and don't have Tk.  cpantesters.org also thinks
that IO::String is the only dependency:

  http://deps.cpantesters.org/?module=Data::Stag;perl=latest

Scott


On Mon, Jul 6, 2009 at 4:26 PM, Dave Messina<David.Messina at sbc.su.se> wrote:
> Hi Steven,
> Forwarding this to the list so that everyone can follow along...please keep
> the list on any replies.
>
> Don't quit out of the install -- cpan can automatically detect required
> dependencies and will try to install them first.
>
> Amidst all of the kerfuffle in your previous install there was this bit:
>
> ---- Unsatisfied dependencies detected during
> [C/CJ/CJFIELDS/BioPerl-1.6.0.tar.gz] -----
>
>    Test::Harness
>
>    Data::Stag
>
>    CPAN
>
> Shall I follow them and prepend them to the queue
>
> of modules we are processing right now? [yes]
>
>
> So if you go back into cpan, try the Bioperl-1.6 install again, you should
> be prompted again about those missing dependencies.
>
>
>
> A note to the Bioperl core-devs:
>
> Data::Stag seems to have a couple of tricky dependencies of its own, namely
> GD and Tk, and it looks like they're for a couple of included scripts which
> I'm guessing Bioperl doesn't use.
>
> Perhaps we should send a request to the Data::Stag author to make GD and Tk
> optional instead of required?
>
>
> Dave
>
>
>
>
> ---------- Forwarded message ----------
> From: Steven McGowan <stevey_mac2k2 at hotmail.com>
> Date: Mon, Jul 6, 2009 at 22:02
> Subject: RE: [Bioperl-l] Bioperl Installation
> To: david.messina at sbc.su.se
>
>
>  Hi Dave,
>
> I managed to sort it and have had a go at
> installing: (install C/CJ/CJFIELDS/BioPerl-db-1.6.0.tar.gz), but upon
> installing have noticed the error:
>
> Checking prerequisites...
>  - ERROR: Data::Stag is not installed
>
> so i have then quit out of the install, and entered "install Data::Stag"
> in>CPAN
>
> but receive the following error messages:
>
> External Module XML::LibXSLT, XSLT,
>  is not installed on this computer.
>  Data::Stag::XSLTHandler in Data::Stag needs it for XSLT Transformations
>
> External Module XML::Parser::PerlSAX, SAX Handler,
>  is not installed on this computer.
>  Data::Stag::XMLParser in Data::Stag needs it for parsing XML
>
> External Module GD, Graphical Drawing Toolkit,
>  is not installed on this computer.
>  stag-drawtree.pl in Data::Stag needs it for drawing trees
>
> External Module Graph::Directed, Generic Graph data stucture and algorithms,
>  is not installed on this computer.
>  Data::Stag::GraphHandler in Data::Stag needs it for transforming stag
> trees to graphs
>
> External Module Tk, Tk,
>  is not installed on this computer.
>  stag-view.pl in Data::Stag needs it for tree viewer
>
> ok so for the C/CJ/CJFIELDS/BioPerl-db-1.6.0.tar.gz install, it's lacking
> Data::Stag who's install is lacking the list above. How would i go about
> installing the above list? is there an easier way or something i'm doing
> wrong?
>
> Thanks,
>
> Stephen
>
> ------------------------------
> From: David.Messina at sbc.su.se
> Date: Mon, 6 Jul 2009 21:38:09 +0200
> Subject: Re: [Bioperl-l] Bioperl Installation
> To: stevey_mac2k2 at hotmail.com
> CC: Bioperl-l at lists.open-bio.org
>
>
> Hi Stephen,
> This is on a Mac, correct?
>
> You need to install the developer tools first. The key line in your log is:
>
>  Can't test without successful make
>
>
> Admittedly, that's cryptic. What it means is that it needs the program
> called make. That program is installed when you install the developer tools.
>
>
> Go to developer.apple.com and create an account if you don't already have
> one.
>
>
> Go to the Mac Dev Center, and click on "Xcode 3".
>
>
> This should be the right link:
>
> Xcode 3
>
> You'll need to login to get to it, and then you'll get to the download page
> for the massive 986 MB Xcode 3.1.3 download.
>
> After you run the Xcode installer, you can check in Terminal that you've got
> 'make' installed by typing:
>
> which make
>
> on the command line. It should give you the answer
> make is /usr/bin/make
>
> If it does, then you're good to try again with the bioperl install.
>
> Dave
>
>
> ------------------------------
> View your Twitter and Flickr updates from one place – Learn
> more!<http://clk.atdmt.com/UKM/go/137984870/direct/01/>
>
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l



-- 
------------------------------------------------------------------------
Scott Cain, Ph. D.                                   scott at scottcain dot net
GMOD Coordinator (http://gmod.org/)                     216-392-3087
Ontario Institute for Cancer Research



More information about the Bioperl-l mailing list