[Bioperl-l] Fwd: [Gmod-ajax] Jbrowse on mac os 10.5

Isabelle Phan isabelle.phan at sbri.org
Mon Mar 16 09:39:29 EDT 2009


Hello Hilmar

Many thanks for your help. I executed the gbrowse installer (which deals
with installing bioperl) with 'sudo'. However, I explicitely set
--install_param_str and
--build_param_str
To a directory in my home directory, e.g. I didn't want to install the
libraries in the default locations, so the package can be wiped out without
breaking my system.

Best greetings

Isabelle

On 3/15/09 11:27 AM, "Chris Fields" <cjfields at illinois.edu> wrote:

> On Mar 15, 2009, at 8:27 AM, Hilmar Lapp wrote:
> 
>> Just forwarding this here in case someone has a moment to check
>> whether there might be anything here that can be improved from the
>> BioPerl side of things. (Note that in Isabelle's case she wouldn't
>> need to install GBrowse and BioPerl in concert.)
>> 
>> -hilmar
>> 
>> Begin forwarded message:
>> 
>> From: iphan <isabelle.phan at sbri.org>
>> Date: March 15, 2009 12:29:10 AM EDT
>> To: "gmod-ajax at lists.sourceforge.net" <gmod-
>> ajax at lists.sourceforge.net>
>> Subject: [Gmod-ajax] Jbrowse on mac os 10.5
>> 
>> Hello
>> 
>> 
>> I've managed to install Jbrowse on my linux box, but somehow the
>> tricks that
>> worked there don't seem to apply to the Mac. What are the minimal
>> set of
>> Gbrowse libraries required for Jbrowse?
>> 
>> Installing GD with Fink was the only step that worked (see big rant
>> below).
>> 
>> Is there a pre-packaged Gbrowse perl library that I can just
>> download and
>> put in my PERL5LIB path to get Jbrowse running?
>> 
>> That would really make my day!
>> 
>> Thanks,
>> 
>> Isabelle
>> 
>> 
>> <big rant>
>> I've spent several hours trying to install Gbrowse on my mac
>> (10.5.6) and
>> can't get it to go past the blasted cpan nightmare. Sorry, had to
>> let my
>> frustration out. I really hate cpan with a vengance, and it probably
>> knows
>> it ;-)
> 
> On Mac OS X one has to use 'sudo' for installation of anything from
> CPAN unless installing to a location the user has read-write privs to,
> like a local directory.  You can set up BioPerl by just downloading
> it, unpacking the tarball, and adding it to PERL5LIB (that's how I run
> it).
> 
>> Errors are inconsistent: cpan can't install either LWP, or Harness,
>> or GD,
>> or Compress::Zlib. I've first tried to execute the Gbrowse installer
>> without
>> any options. It crashes with:
>> 
>> Force getting a BioPerl nightly build; the most recent release is
>> too old
>> 
>> *** Installing BioPerl ***
>> Downloading bioperl-live...
>> Can't locate LWP.pm in @INC (@INC contains:
>> /System/Library/Perl/5.8.8/darwin-thread-multi-2level
>> /System/Library/Perl/5.8.8 /Library/Perl/5.8.8/darwin-thread-
>> multi-2level
>> /Library/Perl/5.8.8 /Library/Perl
>> /Network/Library/Perl/5.8.8/darwin-thread-multi-2level
>> /Network/Library/Perl/5.8.8 /Network/Library/Perl
>> /System/Library/Perl/Extras/5.8.8/darwin-thread-multi-2level
>> /System/Library/Perl/Extras/5.8.8 /Library/Perl/5.8.6 /Library/Perl/
>> 5.8.1)
>> at /System/Library/Perl/Extras/5.8.8/LWP/Simple.pm line 37.
>> 
>> I tried to install LWP from cpan and get:
>> Can't make directory /Users/iphan/.cpan/build/YAML-0.68 read
>> +writeable:
>> Operation not permitted at /System/Library/Perl/5.8.8/CPAN.pm line 966
> 
> Appears to be the same issue described above (need to use 'sudo').
> 
>> I understand that error means I shouldn't have run the gbrowse
>> installer
>> script with 'sudo', but since it won't run otherwise, what the hell
>> am I
>> supposed to do??! Manually do a chmod of .cpan after each installer
>> crash?
>> 
>> I've tried pre-installing Bioperl 7 times, from the tarball, from
>> cpan,
>> from cvs, version 1.6.0, 1.5.x version, dev version (guess that's
>> the same
>> as downloading from cvs?), bioperl-live. None of them seem to play
>> with the
>> Gbrowse perl installer:
>> 
>> *** (back in Bioperl Build.PL) ***
>> Cannot chdir() back to /Users/iphan/.cpan/build/BioPerl-1.6.0: No
>> such file
>> or directory at Bio/Root/Build.pm line 461.
>> Couldn't run Build.PL:
>> /System/Library/Perl/Extras/5.8.8/Module/Build/Compat.pm line 200.
>> Running make test
>> Make had some problems, maybe interrupted? Won't test
>> Running make install
>> Make had some problems, maybe interrupted? Won't install
>> 
>> </big rant
> 
> I may test this out and let you know how it goes; will report back
> what I find.
> 
> chris
> 




More information about the Bioperl-l mailing list