[Bioperl-l] bioperl / emboss on windows

yi wang wangyi2412 at gmail.com
Mon May 4 23:59:54 EDT 2009


Thanks to your good thought, which reminds me doing somthing tracking the
emboss.pm.
I found beside mswin supporting, there is another problem:
*open(WOSSOUT, "wossname -auto |")
is not successful*, so the WOSSOUT is got empty, and the following while
loop does not executed, in which important data is set.

So, does anybody know how to fix this problem?

Thanks very much!

Best Wishes!

2009/5/4 <uludag at ebi.ac.uk>

>
> It looks like EMBOSS was disabled in Bio\Factory\EMBOSS.pm for Windows
> platform. After commenting out the related condition in the _program_list
> function (as shown below) i don't get the "Application [needle] is not
> available" error any more.
>
>    if( #$^O =~ /MSWIN/i ||
>
> Regards,
> Mahmut
>
>
> > I have installed the bioperl and emboss on my* windows xp*, as guided on
> > the web. But it
> > --------------------- WARNING ---------------------
> > *MSG: Application [needle] is not available!*
> > ---------------------------------------------------
> >
> >
> > use warnings;
> > use CGI;
> > use Bio::Perl;
> > use Bio::Root::Root;
> > use Bio::Factory::ApplicationFactoryI;
> > use Bio::Factory::EMBOSS;
> > use Bio::Tools::Run::EMBOSSApplication;
> >
> >
> >
> > *my $f = Bio::Factory::EMBOSS -> new();*
> > *$f->program("needle");*
> > #my $factory = new Bio::Factory::EMBOSS;
> > #my $compseqapp = $factory->program("needle");
>
>
>
>


-- 
ºÍÄãÔÚÒ»Æð



More information about the Bioperl-l mailing list