[Bioperl-l] Eutilities epost/efetch problem

Warren Gallin wgallin at ualberta.ca
Mon May 11 21:35:58 EDT 2009

Hi folks,

	Something started failing for me this morning that had been working  
reliably for the last week,

	I post an array of gi numbers, a history is successfully returned,  
but when I try to use efetch to get the records, it fails with the  

------------- EXCEPTION: Bio::Root::Exception -------------
MSG: Response Error
Not Found
STACK: Error::throw
STACK: Bio::Root::Root::throw /Library/Perl/5.8.8/Bio/Root/Root.pm:368
STACK: Bio::DB::GenericWebAgent::get_Response /Library/Perl/5.8.8/Bio/ 
STACK: 090507_Stable_gb_update.pl:238

	I'm running the efetch inside an eval and letting it try a total of 6  
times with a 5 sedond sleep in between, but the error is consistent.

	So I consider two possibilities:
	1) Has something changed on the Entrez server recently?  Has anyone  
else started having this kind of problem?

	2) Have I inserted some subtle flaw into my code that would lead to a  
failure of efetch.

	I am attaching two text files, one with the code chunklet that is  
doing this and the other the output from the script.

	Any help or suggestions are profoundly appreciated.

Warren Gallin

-------------- next part --------------
A non-text attachment was scrubbed...
Name: Fetch_Fail
Type: application/octet-stream
Size: 2659 bytes
Desc: not available
URL: <http://lists.open-bio.org/pipermail/bioperl-l/attachments/20090511/c09ebc4f/attachment.obj>
-------------- next part --------------

-------------- next part --------------
A non-text attachment was scrubbed...
Name: Fetch_Fail_Output
Type: application/octet-stream
Size: 2685 bytes
Desc: not available
URL: <http://lists.open-bio.org/pipermail/bioperl-l/attachments/20090511/c09ebc4f/attachment-0001.obj>
-------------- next part --------------

More information about the Bioperl-l mailing list