[Bioperl-l] problem with bioperl install

Kristina Fontanez fontanez at fas.harvard.edu
Fri May 29 17:58:12 EDT 2009


Hello everyone-

Sendu - I took your advice but doing Install Bundle::CPAN did not take  
care of the dependencies. It still failed. See attached txt file with  
my terminal output. Does anyone have any idea how this might be?

If I wanted to wipe all perl from my computer and simply start over,  
how might this be accomplished?

Thanks,
Kristina
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: terminalout.txt
URL: <http://lists.open-bio.org/pipermail/bioperl-l/attachments/20090529/ffca822b/attachment-0001.txt>
-------------- next part --------------

---------------------------------------------------------------
Kristina Fontanez
PhD candidate
Department of Organismic and Evolutionary Biology
Cavanaugh lab
Harvard University
16 Divinity Ave.
Cambridge, MA 02138

tel: 617-495-1138
fax: 617-496-6933
email: fontanez at fas.harvard.edu



On May 29, 2009, at 5:34 PM, Sendu Bala wrote:

Mark A. Jensen wrote:
> The message says you are first updating your CPAN.pm.
> That module needs modules you don't have, so
> use cpan to install the dependencies you don't have, viz.
>>    Test::Harness
>>    File::HomeDir
> $ cpan
>> install Test::Harness
> etc.
> Then install CPAN.pm again (or run the Bioperl install again).

Install Bundle::CPAN instead; that will take care of its dependencies  
and leave you in a good state to install BioPerl.

Alternatively, if using and updating CPAN turns into too much of a  
hassle, do it the 'hard way' (which is probably really the easier way):
http://www.bioperl.org/wiki/Installing_Bioperl_for_Unix#INSTALLING_BIOPERL_MODULES_THE_HARD_WAY




More information about the Bioperl-l mailing list