[Bioperl-l] Bioperl 1.6

Guohong Hu ghhu at sibs.ac.cn
Sun Jan 17 21:34:23 EST 2010


Hi there,

 

I was trying to install BioPerl in windows using ppm, by following the
instruction in
"http://bioperl.open-bio.org/wiki/Installing_Bioperl_on_Windows". I set up
the repositories, and did the search of Bioperl packages. The latest version
available is BioPerl 1.6.1 on http://bioperl.org/DIST. When I tried to
install it, a number of prerequisite modules were being installed too, which
include Bioperl 1.4. Then an error message showed up during installation:

 

"ERROR: File conflict for 'C:/Perl/html/bin/bp_aacomp.html'.The package
BioPerl has already installed a file that package bioperl wants to install."

 

It looks to me that BioPerl 1.6.1 had installed a file that bioperl 1.4
wanted to install again. I don't know why bioperl 1.4 was one of the
prerequisites for 1.6.1. If I just install 1.4, it will be installed without
errors. But I need a newer version, because some modules (like

Bio::Tools::HMM) is not included in 1.4.

 

I saw on internet that somebody had the same problem when he was trying to
install BioPerl 1.5, but I didn't find the solution.

 

Anybody has a clue on that? Thank you for your time.

 

GH

 



More information about the Bioperl-l mailing list