[Bioperl-l] Bioperl 1.6

Chris Fields cjfields at illinois.edu
Mon Jan 18 12:18:34 EST 2010


Mark,

Odd issue, maybe it's a dependency like Bio::ASN1::EntrezGene that's causing this?  Regardless, it's problematic for me to test this out directly, at least for the next few days.  Maybe someone could try it?

Also, there is the Strawberry Perl alternative, which uses CPAN (I think ActiveState also supports this).

chris

On Jan 18, 2010, at 10:33 AM, Mark A. Jensen wrote:

> this issue's come up before, see this thread
> http://lists.open-bio.org/pipermail/bioperl-l/2009-October/031400.html
> MAJ
> ----- Original Message ----- From: "Chris Fields" <cjfields at illinois.edu>
> To: "Guohong Hu" <ghhu at sibs.ac.cn>
> Cc: <bioperl-l at lists.open-bio.org>
> Sent: Monday, January 18, 2010 10:30 AM
> Subject: Re: [Bioperl-l] Bioperl 1.6
> 
> 
>> Guohong,
>> 
>> 1.6.1 PPM doesn't (at least, shouldn't) require BioPerl 1.4 to be installed first.  Make sure the repos are set according to the Windows installation instructions on the BioPerl wiki:
>> 
>> http://www.bioperl.org/wiki/Installing_Bioperl_on_Windows
>> 
>> IIRC the actual order of the PPM repository can be critical (PPM pulls based on highest version, first repo, but sometimes it gets confused).  Just curious but where is the v 1.4 PPM located?  If it is local to our PPM repo I can physically remove it to prevent this from happening.
>> 
>> chris
>> 
>> On Jan 17, 2010, at 8:34 PM, Guohong Hu wrote:
>> 
>>> Hi there,
>>> 
>>> 
>>> 
>>> I was trying to install BioPerl in windows using ppm, by following the
>>> instruction in
>>> "http://bioperl.open-bio.org/wiki/Installing_Bioperl_on_Windows". I set up
>>> the repositories, and did the search of Bioperl packages. The latest version
>>> available is BioPerl 1.6.1 on http://bioperl.org/DIST. When I tried to
>>> install it, a number of prerequisite modules were being installed too, which
>>> include Bioperl 1.4. Then an error message showed up during installation:
>>> 
>>> 
>>> 
>>> "ERROR: File conflict for 'C:/Perl/html/bin/bp_aacomp.html'.The package
>>> BioPerl has already installed a file that package bioperl wants to install."
>>> 
>>> 
>>> 
>>> It looks to me that BioPerl 1.6.1 had installed a file that bioperl 1.4
>>> wanted to install again. I don't know why bioperl 1.4 was one of the
>>> prerequisites for 1.6.1. If I just install 1.4, it will be installed without
>>> errors. But I need a newer version, because some modules (like
>>> 
>>> Bio::Tools::HMM) is not included in 1.4.
>>> 
>>> 
>>> 
>>> I saw on internet that somebody had the same problem when he was trying to
>>> install BioPerl 1.5, but I didn't find the solution.
>>> 
>>> 
>>> 
>>> Anybody has a clue on that? Thank you for your time.
>>> 
>>> 
>>> 
>>> GH
>>> 
>>> 
>>> 
>>> _______________________________________________
>>> Bioperl-l mailing list
>>> Bioperl-l at lists.open-bio.org
>>> http://lists.open-bio.org/mailman/listinfo/bioperl-l
>> 
>> 
>> _______________________________________________
>> Bioperl-l mailing list
>> Bioperl-l at lists.open-bio.org
>> http://lists.open-bio.org/mailman/listinfo/bioperl-l
> 




More information about the Bioperl-l mailing list