[Bioperl-l] Bioperl 1.6

Guohong Hu ghhu at sibs.ac.cn
Mon Jan 18 21:22:19 EST 2010

Thank for you all. The problem is solved. The bioperl 1.4 version is from
the Trouchelle repo, but 1.6 is in the Bioperl Regular Releases repo. When I
added all the repo according to the bioperl wiki instruction, somehow 1.4
became a prerequisite for 1.6. But Chris's question reminded me, so I
removed Trouchelle repo, and the installation proceeded without errors. I
suggested we put a note in the wiki link since it looks like an odd issue
not just for me.


·¢¼þÈË: Chris Fields [mailto:cjfields at illinois.edu] 
·¢ËÍʱ¼ä: 2010Äê1ÔÂ18ÈÕ 23:30
ÊÕ¼þÈË: Guohong Hu
³­ËÍ: bioperl-l at lists.open-bio.org
Ö÷Ìâ: Re: [Bioperl-l] Bioperl 1.6


1.6.1 PPM doesn't (at least, shouldn't) require BioPerl 1.4 to be installed
first.  Make sure the repos are set according to the Windows installation
instructions on the BioPerl wiki:


IIRC the actual order of the PPM repository can be critical (PPM pulls based
on highest version, first repo, but sometimes it gets confused).  Just
curious but where is the v 1.4 PPM located?  If it is local to our PPM repo
I can physically remove it to prevent this from happening.


On Jan 17, 2010, at 8:34 PM, Guohong Hu wrote:

> Hi there,
> I was trying to install BioPerl in windows using ppm, by following the
> instruction in
> "http://bioperl.open-bio.org/wiki/Installing_Bioperl_on_Windows". I set up
> the repositories, and did the search of Bioperl packages. The latest
> available is BioPerl 1.6.1 on http://bioperl.org/DIST. When I tried to
> install it, a number of prerequisite modules were being installed too,
> include Bioperl 1.4. Then an error message showed up during installation:
> "ERROR: File conflict for 'C:/Perl/html/bin/bp_aacomp.html'.The package
> BioPerl has already installed a file that package bioperl wants to
> It looks to me that BioPerl 1.6.1 had installed a file that bioperl 1.4
> wanted to install again. I don't know why bioperl 1.4 was one of the
> prerequisites for 1.6.1. If I just install 1.4, it will be installed
> errors. But I need a newer version, because some modules (like
> Bio::Tools::HMM) is not included in 1.4.
> I saw on internet that somebody had the same problem when he was trying to
> install BioPerl 1.5, but I didn't find the solution.
> Anybody has a clue on that? Thank you for your time.
> GH
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l

More information about the Bioperl-l mailing list