[Bioperl-l] ./Build install doesn't install bioperl-run

Peng Yu pengyu.ut at gmail.com
Sun Jun 6 11:15:24 EDT 2010

On Sun, Jun 6, 2010 at 9:16 AM, Dave Messina <David.Messina at sbc.su.se> wrote:
>> My perl is installed in a directory in my home. I think that bioperl
>> will be installed in the directory in the perl directory in my home,
>> right?
> Hmm, I think you still have to tell Build that you want it to install in your private directory.
> Have you read
> http://www.bioperl.org/wiki/Installing_Bioperl_for_Unix#INSTALLING_BIOPERL_IN_A_PERSONAL_MODULE_AREA

I actually read the description. But I don't understand why it is the case.

When I download other packages from CPAN. I don't need to specify
anything. They get automatically installed in a directory (I think it
is site_perl?) in my local perl installation directory. Why I have to
explicitly say where bioperl should be installed ?

> ?
>> BTW, the following web address better be changed to 'Using_git".
>> http://www.bioperl.org/wiki/Using_Subversion
> Actually, the page is Using_git, but we're redirecting Using_Subversion to it; that's why it looks like URL is wrong.
> Also, I think we tried to change all of the links on the website to point to Using_git. May I ask where did you see — that is, how did you come to — the link to Using_subversion?

Please see the following webpage.Search for "Using Subversion".


>>> Can you post the whole transcript of your failed install?
>> I assume that you are asking the Build script. Please see the
>> attachment. Let me know if you mean something else.
> No, I mean could you copy and paste the command line text showing the commands you ran (starting with 'perl Build.PL' and up to and including './Build install'), and including the output from running those commands?

Once, I saw some installing command after "Building BioPerl-Run" when
I run '.Build install". But I can not reproduce it any more.

I delete the download and run the installation process again. But it
still doesn't seem to work.

$ git clone git://github.com/bioperl/bioperl-run.git
Initialized empty Git repository in
remote: Counting objects: 11230, done.
remote: Compressing objects: 100% (2502/2502), done.
remote: Total 11230 (delta 7360), reused 11184 (delta 7322)
Receiving objects: 100% (11230/11230), 25.84 MiB | 18.20 MiB/s, done.
Resolving deltas: 100% (7360/7360), done.
Checking out files: 100% (379/379), done.

$ perl Build.PLInstall scripts? y/n [n ]
Do you want to run tests that require connection to servers across the internet
(likely to cause some failures)? y/n [n ]
  - will not run internet-requiring tests
Creating new 'MYMETA.yml' with configuration results
Can't find dist packages without a MANIFEST file
Run 'Build manifest' to generate one

WARNING: Possible missing or corrupt 'MANIFEST' file.
Nothing to enter for 'provides' field in metafile.
Creating new 'Build' script for 'BioPerl-Run' version '1.006900'

$ ./Build manifest
File 'MANIFEST.SKIP' does not exist: Creating a temporary 'MANIFEST.SKIP'
Added to MANIFEST: Build.PL
Added to MANIFEST: Changes
Added to MANIFEST: t/TCoffee.t
Added to MANIFEST: t/TigrAssembler.t
Added to MANIFEST: t/Tmhmm.t
Added to MANIFEST: t/TribeMCL.t
Added to MANIFEST: t/tRNAscanSE.t
Added to MANIFEST: t/Vista.t

$ ./Build install
Building BioPerl-Run


More information about the Bioperl-l mailing list