[Bioperl-l] ./Build install doesn't install bioperl-run

Dave Messina David.Messina at sbc.su.se
Sun Jun 6 12:26:04 EDT 2010

On Jun 6, 2010, at 17:15, Peng Yu <pengyu.ut at gmail.com> wrote:

> When I download other packages from CPAN. I don't need to specify
> anything. They get automatically installed in a directory (I think it
> is site_perl?) in my local perl installation directory. Why I have to
> explicitly say where bioperl should be installed ?

Ah okay, I misunderstood. If it works for other CPAN installs, it  
should work for BioPerl.

>>> BTW, the following web address better be changed to 'Using_git".
>>> http://www.bioperl.org/wiki/Using_Subversion
>> Actually, the page is Using_git, but we're redirecting  
>> Using_Subversion to it; that's why it looks like URL is wrong.
>> Also, I think we tried to change all of the links on the website to  
>> point to Using_git. May I ask where did you see — that is, how did 
>>  you come to — the link to Using_subversion?
> Please see the following webpage.Search for "Using Subversion".
> http://www.bioperl.org/wiki/HOWTO:BlastPlus


> I delete the download and run the installation process again. But it
> still doesn't seem to work.

I'll take a look at this later.

In the meantime, you can certainly do as Chris recommended earlier and  
not 'install' and just add bioperl-run/lib to your PERL5LIB.

As he said, that's better anyway, since you can keep up-to-date with  
the latest bug fixes and changes by simply doing 'git pull'.


More information about the Bioperl-l mailing list