[Bioperl-l] NetBlast path. Not found.

Rikusia rikusia at gmail.com
Sat Jun 19 05:20:58 EDT 2010

I have code like this: 

#!/usr/bin/perl -w
use strict;
use warnings;
use Bio::SearchIO;
my $netblast_dir = $ENV{USERPROFILE} . "\\Desktop\\netblast";
my $blast_report;

chdir ($netblast_dir) or die;

system ("blastcl3 -p blastn -d nr -i in.fasta -o out.blast");

$blast_report = new Bio::SearchIO ('-format' => 'blast', '-file' =>

while ( my $result = $blast_report->next_result ) {
    my $hit_num = 0;
    while( my $hit = $result->next_hit ) {
    while( my $hsp = $hit->next_hsp ) {
        my $hsp_num++;
        my $hitName = $hit->name;
        my $percent_id = sprintf ("%.2f", $hsp->percent_identity);
        my $hspLength = $hsp->hsp_length;
        my $hspStart = $hsp->start('hit');
        my $hspEnd = $hsp->end('hit');
        my $numID = $hsp->num_identical;
        my $numGaps = $hsp->gaps;
        print "Hit number: $hit_num, hsp number: $hsp_num\n\t$hitName\n" .
        "\t\tPercent ID: $percent_id\n" .
        "\t\tLength:  $hspLength\n" .
        "\t\tRange: $hspStart - $hspEnd\n" .
        "\t\tIdentical residues: $numID\n" .
        "\t\tGaps: $numGaps\n\n";

print "Done.\n";

I'm using netblast, but still Path to blastall cannot be found and changing
windows enviroment variables is not helping. Do you have any ideas how to
fix it? 
View this message in context: http://old.nabble.com/NetBlast-path.-Not-found.-tp28933539p28933539.html
Sent from the Perl - Bioperl-L mailing list archive at Nabble.com.

More information about the Bioperl-l mailing list