[Bioperl-l] Trouble about Bio::Tools::Run::Alignment::Clustalw

Chris Fields cjfields at illinois.edu
Tue Mar 30 08:42:24 EDT 2010


You may need to submit this as a bug.  I got clustalw2 working fairly recently, but it's possible some other API change is breaking things.

chris

On Mar 29, 2010, at 11:03 PM, click xu wrote:

> Russell
> Clustalw2 can correctly run in command line, and the /tmp space is enough too.
> 
> 
> 2010/3/30 Smithies, Russell <Russell.Smithies at agresearch.co.nz>:
>> Do you have enough temp space?
>> Will clustalw run 'manually' with your parameters from the command line?
>> 
>> --Russell
>> 
>>> -----Original Message-----
>>> From: bioperl-l-bounces at lists.open-bio.org [mailto:bioperl-l-
>>> bounces at lists.open-bio.org] On Behalf Of click xu
>>> Sent: Tuesday, 30 March 2010 4:17 p.m.
>>> To: bioperl-l at lists.open-bio.org
>>> Subject: [Bioperl-l] Trouble about Bio::Tools::Run::Alignment::Clustalw
>>> 
>>> Hi,
>>> I meet a problem when using Clustalw module.
>>> Here is the error message:
>>> ------------- EXCEPTION: Bio::Root::Exception -------------
>>> MSG: ClustalW call ( align  -infile=/tmp/AeyAfdxGvH/YpcPbyhYht
>>> -output=gcg   -matrix=BLOSUM -ktup
>>> le=2 -outfile=/tmp/AeyAfdxGvH/Z2MbO0ylbF 2>&1) failed to start: 0 |
>>> cannot find the file or path
>>> STACK: Error::throw
>>> STACK: Bio::Root::Root::throw /home/lf/data/BioPerl-
>>> 1.6.1/Bio/Root/Root.pm:368
>>> STACK: Bio::Tools::Run::Alignment::Clustalw::_run
>>> /usr/local/share/perl/5.10.0/Bio/Tools/Run/Alig
>>> nment/Clustalw.pm:756
>>> STACK: Bio::Tools::Run::Alignment::Clustalw::align
>>> /usr/local/share/perl/5.10.0/Bio/Tools/Run/Ali
>>> gnment/Clustalw.pm:515
>>> STACK: test.txt:45
>>> -----------------------------------------------------------
>>> The test program is described as below:
>>> -----------------------------------------------------------
>>> @params = ('ktuple' => 2, 'matrix' => 'BLOSUM');
>>> $factory = Bio::Tools::Run::Alignment::Clustalw->new(@params);
>>> # @seq_array is an array of Bio::Seq objects
>>> $aln = $factory->align(\@seq_array);
>>> -----------------------------------------------------------
>>> The work path of clustalw2 has been configured:
>>> export CLUSTALDIR=/usr/local/bin/clustalw2
>>> So, what may be reason of the error?
>>> Thanks!
>>> 
>>> _______________________________________________
>>> Bioperl-l mailing list
>>> Bioperl-l at lists.open-bio.org
>>> http://lists.open-bio.org/mailman/listinfo/bioperl-l
>> =======================================================================
>> Attention: The information contained in this message and/or attachments
>> from AgResearch Limited is intended only for the persons or entities
>> to which it is addressed and may contain confidential and/or privileged
>> material. Any review, retransmission, dissemination or other use of, or
>> taking of any action in reliance upon, this information by persons or
>> entities other than the intended recipients is prohibited by AgResearch
>> Limited. If you have received this message in error, please notify the
>> sender immediately.
>> =======================================================================
>> 
> 
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l




More information about the Bioperl-l mailing list