[Bioperl-l] [bioperl-network] Not indexed by CPAN (#1)

Chad Davis chad.a.davis at gmail.com
Fri Oct 14 08:48:19 EDT 2011


Because it may be related, I wanted to mention that I am having the
same problem with Bioperl-Run. In this case, however, I can find the
distribution via:

i /bioperl-run/

But searching for a containing module does not return the distribution:

i /clustalw/

Chad

On Fri, Oct 14, 2011 at 03:45, Brian Osborne <bosborne11 at verizon.net> wrote:
> Chris,
>
> OK, tell me what they say when you hear from them.
>
> BIO
>
>
> On Oct 13, 2011, at 1:03 PM, Fields, Christopher J wrote:
>
>> There is apparently some funkiness with the indexing and the META.yml file 'provides' section.  I've emailed modules at perl to see if they can diagnose it.  It's likely due to the version in that section.
>>
>> chris
>>
>> On Oct 13, 2011, at 10:52 AM, Brian Osborne wrote:
>>
>>> Yes, BOSBORNE.
>>>
>>> On Oct 13, 2011, at 11:47 AM, Fields, Christopher J wrote:
>>>
>>>> Brian,
>>>>
>>>> If you have a PAUSE ID, I think I can set this up so you can submit new releases (just need to add you as a secondary maintainer).  Is yours BOSBORNE?
>>>>
>>>> It's odd that CPAN isn't indexing this, though; it's popping up on search.cpan.org.  I did notice that cpanm attempted to install an older version (1.6.0).  I'll try a new upload (1.6.901), see if that helps.
>>>>
>>>> chris
>>>>
>>>> On Oct 13, 2011, at 8:07 AM, Brian Osborne wrote:
>>>>
>>>>> bioperl-l,
>>>>>
>>>>> It looks like bioperl-network is not indexed by CPAN, I don't think I have the privileges at CPAN to do this.
>>>>>
>>>>> Brian O.
>>>>>
>>>>> Begin forwarded message:
>>>>>
>>>>>> From: "Chad A. Davis" <reply+i-1899390-b955d156f163b5a53fbf88e3f2e177363804adfa at reply.github.com>
>>>>>> Date: October 13, 2011 7:40:27 AM EDT
>>>>>> To: bosborne <bosborne11 at verizon.net>
>>>>>> Subject: [bioperl-network] Not indexed by CPAN (#1)
>>>>>>
>>>>>> I have code managed by Module::Install that depends on Bio::Network::ProteinNet. Module::Install cannot automatically fetch and install the dependency. It seems that the bioperl-network modules are not indexed by CPAN at the moment. You should see the problem if you try to "install Bio::Network::ProteinNet" from the CPAN shell. My workaround is currently to "install CJFIELDS/BioPerl-Network-1.006900.tar.gz" from the CPAN shell. That works, but I cannot give a name like that to Module::Install in my Makefile.PL. Users of my code have to install bioperl-network as an additional step.
>>>>>>
>>>>>> This is perl 5, version 12, subversion 4 (v5.12.4) built for x86_64-linux-gnu-thread-multi
>>>>>>
>>>>>> CPAN 1.9800
>>>>>>
>>>>>> --
>>>>>> Reply to this email directly or view it on GitHub:
>>>>>> https://github.com/bioperl/bioperl-network/issues/1
>>>>>
>>>>>
>>>>> _______________________________________________
>>>>> Bioperl-l mailing list
>>>>> Bioperl-l at lists.open-bio.org
>>>>> http://lists.open-bio.org/mailman/listinfo/bioperl-l
>>>>
>>>
>>
>>
>> _______________________________________________
>> Bioperl-l mailing list
>> Bioperl-l at lists.open-bio.org
>> http://lists.open-bio.org/mailman/listinfo/bioperl-l
>
>
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l
>



More information about the Bioperl-l mailing list