[Bioperl-l] algorithm_version not working in multi-result blast output

Fields, Christopher J cjfields at illinois.edu
Wed Sep 28 17:40:48 EDT 2011

Not sure, but I would hazard a guess that only the 'Query=' line is present in concatenated BLAST reports past the initial report, and the version isn't carried over (I recall this being a problem with the algorithm() as well, but that was fixed a while ago.  

This should be an easy enough fix, but can you submit it as a bug so we can track it?


On Sep 28, 2011, at 11:54 AM, Paul Cantalupo wrote:

> Hello,
> I'm using the most recent copy of bioperl-live (pulled yesterday). I
> have a BLASTN (from blast+) output file for 3 query sequences
> (https://gist.github.com/1248342). I used this script,
> https://gist.github.com/1248338, to print the query id, algorithm and
> algorithm_version for each result. When I run the script, I get the
> following output:
> GFAVMM201BADC0  BLASTN  2.2.25+
> Algorithm_version outputs the correct version for the first result but
> outputs the empty string for the 2nd and 3rd query. Why? This
> functionality worked about a month ago. What has changed to cause this
> to happen?
> Thank you,
> Paul
> _______________________________________________
> Bioperl-l mailing list
> Bioperl-l at lists.open-bio.org
> http://lists.open-bio.org/mailman/listinfo/bioperl-l

More information about the Bioperl-l mailing list