[Bioperl-l] Problems installing BioPerl & cpan

Merche Castillo merche at uni-bonn.de
Mon Apr 23 08:31:27 EDT 2012


I'm posting this message out of pure desperation, because I really don't 
know what else to try. I'm a beginner in bioperl and I'm working on a 
script to parse out some results I got from MolQuest fgenesh. Results 
are out in .txt format and I want to parse them to GFF and fasta file 
for mRNA and protein sequences to facilitate comparison with other 
results we have. I would like to use BioPerl for other purposes in the 
future so I'm very interested in getting it ready on my pc

I followed the instructions 
herehttp://www.bioperl.org/wiki/Installing_Bioperl_for_Unix. I managed 
to install CPAN in root mode (otherwise it wouldn't work) and BioPerl 
via CPAN. All tests were ok, but when I ran this script to test the 
installation

|  use strict;
  use warnings;

  use Getopt::Long;
  use Bio::EnsEMBL::Registry;

  my $reg = "Bio::EnsEMBL::Registry";
  $reg->load_registry_from_db(
               -host =>  "ensembldb.ensembl.org",
               -user =>  "anonymous"
  );
  my $db_list=$reg->get_all_adaptors();
  my @line;

foreach my $db (@$db_list){
     @line = split ('=',$db);
     print $line[0]."\n";
  }
|

I got the error:*"Can't locate Bio/EnsEMBL/Registry.pm in @INC"*

I tried to install BioPerl again via Build.PL, running as root, but 
still came to the same outcome.

Thanks for your help Merche

-- 
************************************;)
Mercedes Castillo
INRES, Dept. Molecular Phytomedicine
University of Bonn

Karlrobert-Kreiten-str 13
53115 Bonn
+49(0)22873-60143
merche at uni-bonn.de
*****************************************



More information about the Bioperl-l mailing list