[Bioperl-l] error during installation

Du, Peng du at ibio.jp
Fri Jun 15 23:28:47 EDT 2012

Hi everybody,

I am a newbie, I encountered a problem while installing bioperl-ext.
The error message is :

/usr/bin/ld: libs/libsw.a(aln.o): relocation R_X86_64_32 against
`.rodata.str1.8' can not be used when making a shared object;
recompile with -fPIC
libs/libsw.a: could not read symbols: Bad value
collect2: ld returned 1 exit status

I googled some solutions, but all of them are confusing, could you
tell me where exactly should I add the -fPIC? In the makefile under
the bioperl-ext-1.4 directory?  I tried to add this to the CCCDLFLAGS,
CCDLFLAGS, LDDLFLAGS and LDFLAGS in that file. But it still doesn't

Could you tell me what to do or where could I find the answer?

Thank you very much.

Best Regards,


Peng Du
Graduate School of Information Science and Technology, Hokkaido University
Kita 14 Nishi 9 Kita-ku, Sapporo, Japan  060-0814
Email: du at ibio.jp Tel: +81 80 3268 9713

More information about the Bioperl-l mailing list