[Bioperl-l] error during installation

Leon Timmermans l.m.timmermans at students.uu.nl
Sat Jun 16 04:50:35 EDT 2012


On Sat, Jun 16, 2012 at 5:28 AM, Du, Peng <du at ibio.jp> wrote:
> Hi everybody,
>
> I am a newbie, I encountered a problem while installing bioperl-ext.
> The error message is :
>
>
> /usr/bin/ld: libs/libsw.a(aln.o): relocation R_X86_64_32 against
> `.rodata.str1.8' can not be used when making a shared object;
> recompile with -fPIC
> libs/libsw.a: could not read symbols: Bad value
> collect2: ld returned 1 exit status
>
> I googled some solutions, but all of them are confusing, could you
> tell me where exactly should I add the -fPIC? In the makefile under
> the bioperl-ext-1.4 directory?  I tried to add this to the CCCDLFLAGS,
> CCDLFLAGS, LDDLFLAGS and LDFLAGS in that file. But it still doesn't
> work.
>f
> Could you tell me what to do or where could I find the answer?
>
> Thank you very much.
>
> Best Regards,
> Peng

You should not install it in the first place. BioPerl-ext has been
partly merged into the main Bioperl distribution, and partly spun off
into its own dists (Bio::Tools::HMM, not released yet AFAIK). You
should just install the former, or help release the latter.

Leon



More information about the Bioperl-l mailing list