[Bioperl-l] compiling Bio::Perl error in Bio/Root

Georg Vogler gvogler at sanfordburnham.org
Tue Oct 23 22:57:09 EDT 2012


Thanks for your replies. Yes, the Ubuntu package is up-to-date, but since
I'm installing all tools from source I think it should be possible for
Bioperl as well. Installing Ubuntu packages also seems to interfere with
my custom installations.

Chris, you were right on the spot (it seems). perldoc Clone shows a
manpage. I then did 'cpanm Clone' and that installed it and the problem
was solved (it also solved a 'clone' problem in WebGBrowse :-) _.

Bio::root compiled just fine.

t/Root/HTTPget.t ............................. skipped: Network tests have
not been requested
t/Root/RootI.t ............................... ok
t/Root/RootIO.t .............................. ok
t/Root/Storable.t ............................ ok
t/Root/Tempfile.t ............................ ok

Since I tried installing the Ubuntu Bioperl package before, I have another
problem when compiling Bioperl (I'm stubborn).


It seems the package now threw off my original samtools installation, and
I an error occurs where there was none before

Bio::Assembly::IO: could not load sam - for more details on supported
formats please see the Assembly::IO docs

But that's another story.

Thanks again,

Geo







Am 10/23/12 7:10 PM schrieb "Fields, Christopher J" unter
<cjfields at illinois.edu>:

>If this package represents the latest CPAN release, then that works.
>Otherwise it may be quite out of date.
>
>The error in question is a bit odd, as it hasn't popped up before with
>testing (at least that I have seen).  The clone() method will alias to
>Storable's dclone() if Clone isn't installed; somehow it thinks Clone is
>present when it isn't (or there is a Clone module installed w/o the
>clone() method). Can you run 'perldoc Clone' to see if Clone is
>installed?  
>
>chris
>
>On Oct 23, 2012, at 8:31 PM, longbow leo <longbow0 at gmail.com>
> wrote:
>
>> Hi,
>> 
>> There is a "bioperl" package in ubuntu repository. It is not need to
>> compile and install it.
>> 
>> Best,
>> 
>> Haizhou
>> 
>> On Wed, Oct 24, 2012 at 8:42 AM, Georg Vogler
>><gvogler at sanfordburnham.org>wrote:
>> 
>>> Hi!
>>> 
>>> I'm having trouble compiling Bio::Perl on my Ubuntu 12.04 server. Here
>>>is
>>> the excerpt (I removed some lines from tests that passed) from the
>>> build.log after running "sudo cpanm Bio::Perl":
>>> 
>>> Searching Bio::Perl on cpanmetadb ...
>>> --> Working on Bio::Perl
>>> Fetching
>>> http://www.cpan.org/authors/id/C/CJ/CJFIELDS/BioPerl-1.6.901.tar.gz
>>> -> OK
>>> Unpacking BioPerl-1.6.901.tar.gz
>>> Entering BioPerl-1.6.901
>>> Checking configure dependencies from META.yml
>>> Checking if you have Module::Build 0.38 ... Yes (0.4003)
>>> Configuring BioPerl-1.006901
>>> Running Build.PL
>>> Do you want to run the Bio::DB::GFF or Bio::DB::SeqFeature::Store live
>>> database tests? y/n [n]   - will not run the BioDBGFF or
>>>BioDBSeqFeature
>>> live database t
>>> ests
>>> 
>>> Install [a]ll BioPerl scripts, [n]one, or choose groups
>>>[i]nteractively?
>>> [a]   - will install all scripts
>>> 
>>> Do you want to run tests that require connection to servers across the
>>> internet
>>> (likely to cause some failures)? y/n [n]   - will not run
>>> internet-requiring tests
>>> Created MYMETA.yml and MYMETA.json
>>> Creating new 'Build' script for 'BioPerl' version '1.006901'
>>> -> OK
>>> Checking dependencies from MYMETA.json ...
>>> Checking if you have Test::More 0 ... Yes (0.98)
>>> Checking if you have Test::Harness 2.62 ... Yes (3.25)
>>> Checking if you have CPAN 1.81 ... Yes (1.9800)
>>> Checking if you have Module::Build 0.2805 ... Yes (0.4003)
>>> Checking if you have Scalar::Util 0 ... Yes (1.23)
>>> Checking if you have IO::String 0 ... Yes (1.08)
>>> Checking if you have Data::Stag 0.11 ... Yes (0.11)
>>> Checking if you have DB_File 0 ... Yes (1.821)
>>> Checking if you have ExtUtils::Manifest 1.52 ... Yes (1.61)
>>> Building and testing BioPerl-1.006901
>>> Building BioPerl
>>> t/Align/AlignStats.t ......................... ok
>>> t/Align/AlignUtil.t .......................... ok
>>> t/Align/Graphics.t ........................... ok
>>> t/Align/SimpleAlign.t ........................ ok
>>> t/Align/TreeBuild.t .......................... ok
>>> 
>>> Š
>>> 
>>> t/Assembly/IO/bowtie.t ....................... skipped: The optional
>>> module Bio::Tools::Run::Samtools (or dependencies thereof) was not
>>>installed
>>> t/Assembly/IO/sam.t .......................... skipped: The optional
>>> module Bio::DB::Sam (or dependencies thereof) was not installed
>>> 
>>> Š
>>> 
>>> t/Restriction/Analysis-refac.t ............... ok
>>> t/Restriction/Analysis.t ..................... ok
>>> t/Restriction/Gel.t .......................... ok
>>> t/Restriction/IO.t ........................... ok
>>> t/Root/Exception.t ........................... ok
>>> t/Root/HTTPget.t ............................. skipped: Network tests
>>>have
>>> not been requested
>>> Undefined subroutine &Clone::clone called at Bio/Root/Root.pm line 214.
>>> # Looks like you planned 63 tests but ran 51.
>>> # Looks like your test exited with 255 just after 51.
>>> t/Root/RootI.t ...............................
>>> Dubious, test returned 255 (wstat 65280, 0xff00)
>>> Failed 12/63 subtests
>>> 
>>> Š
>>> 
>>> 
>>> ------------- EXCEPTION: Bio::Root::Exception -------------
>>> MSG: Unallowed parameter: clone !
>>> STACK: Error::throw
>>> STACK: Bio::Root::Root::throw Bio/Root/Root.pm:472
>>> STACK: Bio::Tools::Primer3::AUTOLOAD Bio/Tools/Primer3.pm:150
>>> STACK: Bio::Tools::Primer3::next_primer Bio/Tools/Primer3.pm:338
>>> STACK: t/Tools/Primer3.t:26
>>> -----------------------------------------------------------
>>> 
>>> Š
>>> 
>>> Test Summary Report
>>> -------------------
>>> t/Root/RootI.t                             (Wstat: 65280 Tests: 51
>>>Failed:
>>> 0)
>>>  Non-zero exit status: 255
>>>  Parse errors: Bad plan.  You planned 63 tests but ran 51.
>>> t/SeqFeature/Clone.t                       (Wstat: 65280 Tests: 0
>>>Failed:
>>> 0)
>>>  Non-zero exit status: 255
>>>  Parse errors: Bad plan.  You planned 17 tests but ran 0.
>>> t/Tools/Primer3.t                          (Wstat: 65280 Tests: 8
>>>Failed:
>>> 0)
>>>  Non-zero exit status: 255
>>>  Parse errors: Bad plan.  You planned 14 tests but ran 8.
>>> Files=349, Tests=22654, 157 wallclock secs ( 3.58 usr  0.73 sys +
>>>141.69
>>> cusr  9.30 csys = 155.30 CPU)
>>> Result: FAIL
>>> Failed 3/349 test programs. 0/22654 subtests failed.
>>> -> FAIL Installing Bio::Perl failed. See /home/gvogler/.cpanm/build.log
>>> for details.
>>> 
>>> 
>>> Any suggestions are greatly appreciated!
>>> 
>>> Many thanks,
>>> 
>>> Geo
>>> 
>>> 
>>> 
>>> _______________________________________________
>>> Bioperl-l mailing list
>>> Bioperl-l at lists.open-bio.org
>>> http://lists.open-bio.org/mailman/listinfo/bioperl-l
>>> 
>> 
>> _______________________________________________
>> Bioperl-l mailing list
>> Bioperl-l at lists.open-bio.org
>> http://lists.open-bio.org/mailman/listinfo/bioperl-l
>




More information about the Bioperl-l mailing list